The small linux problem thread

Try vanilla Debian. I personally run Debian SID/Unstable as my daily. Come to the “right” side.

My Asus G50VT-X5 is being bitchy. It has a 9800M GS and after I install an OS and install NV 340xx the desktop will just freeze. IDEK what to do about it or look for.

Having never used debian, didn’t even see how to boot with nomodeset. Trying 'buntu 18.10 beta now Dje4321, With Nvidia 390 installed, set apt-hold for Nvidia-390 (not in front of it right now to get the name right) and we’ll see if it was an Nvidia driver update breaking things.


Blacklisted nouveau, that didn’t do shit. Seems to happen when I open chrome… Lets try firefox :U

ok it doesn’t seem to matter what I open it just freezes after a few minutes. I can still move my mouse though.

I dunno what to do now I can’t think what is wrong and journalctl doesn’t say anything useful.

Picture of journalctl

This i- what it says as its frozen.

Is this a random lockup after a while or are you unable to get to the display manager?

Aaahhh, I’ve been actually struggling with the same thing on Fedora, but I’m on a 10 series with NV 390. Firefox is my primary browser and it happens with firefox. I’m thinking it’s either a powermanagement thing or an interrupt issue.

This is in deepin.

…Well fuck thats not exactly exciting to hear. And I just have 340.106, I’m not even close to the newest drivers…

Well fuck now what do I do.

I don’t know. I’ve been living with it. It’s one of those things that happens once a day for me.

nouveau didn’t have the problem, so if you don’t need full performance for the time being, switching to them would be my recommendation. I’ll definitely keep you appraised if I make any progress though. It’s been a 2-3 month struggle.

Only reason I need proprietary drivers is for the L1KVM. nouveau doesn’t like it.

1 Like

I need a laptop to play TF2 on till my Oryx gets here D: aww man

Ah, I get that.

I’ll keep digging into this.

EDIT: Are you able to switch to a TTY after the freeze?

1 Like

Nope… Not at all. Most I can do is have a terminal open at the driver crash.

Maybe its a gnome thing? Are you on gnome? Deepin is built on top of gnome… Chris from JB has this happen constantly.

1 Like

Yeah, I’m running Fedora with Gnome. Might be time to try kde…

Damn Gnome.

Launchpad bug that seems to be related, except this guy can switch TTY:

1 Like

Anyone played around with clonedeploy? I installed it once on an Ubuntu VM, but wiped it. Just tried installing in on a Fedora VM and I can’t access the web interface:

I followed the Centos 7 guide (here) very closely. Every step either worked straight over to Fedora, or was convertable to the way Fedora does things. In either case, I was able to do each step without issue. I checked that all the services that were created are started, and I double checked that the config files were correct.

It’s probably something simple, but I just don’t know what isn’t working right. What would cause an error like that?

Beware, they left out config of the first line of guide: “This guide assumes selinux is disabled.”

$ cat /etc/sysconfig/selinux 

# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#     enforcing - SELinux security policy is enforced.
#     permissive - SELinux prints warnings instead of enforcing.
#     disabled - No SELinux policy is loaded.
# SELINUXTYPE= can take one of these three values:
#     targeted - Targeted processes are protected,
#     minimum - Modification of targeted policy. Only selected processes are protected. 
#     mls - Multi Level Security protection.

Check journalctl out as well, it’s probably a permissions issue somewhere.

$ journalctl -xb
-- Logs begin at Fri 2018-03-16 19:11:54 PDT, end at Sat 2018-04-14 20:15:01 PDT. --


Yeah, yeah. So sue me.

$ grep CMDLINE /etc/sysconfig/grub
GRUB_CMDLINE_LINUX="rhgb quiet net.ifnames=0 pti=off spectre_v2=off"

haha I’m just saying, learning to actually use selinux is better if you have the time.

Did a fresh reboot of the VM and went through the journalctl. About the only thing that stood out to me is mono is crashing and dumping core, and it is then blacklisting the package.

Did it work with CentOS 7?

I’ve tried to watch that RedHat youtube video on the stopdisablingselinux page several times. I get about 1 minute into it.

It worked under Ubuntu the last time I did this. Maybe I’ll just try to run that instead.