The small linux problem thread



To elaborate:

[[email protected] testdir]# ls -1
[[email protected] testdir]# files=()
[[email protected] testdir]# read -d $"\n" -a files <<< "$( ls )" && echo "Success" || echo "Failure"
[[email protected] testdir]# echo "${files[@]}"
f1 f2 f3 f4 f5
[[email protected] testdir]# echo "${files[0]}"
[[email protected] testdir]# echo "${files[4]}"

I don’t understand the effect of <<< on && vs ||.

Nevermind, read -d $"\n" ... should be read -d $'\n' .... It works but quietly fails if you use double quotes.

Hey, thanks for the response! You really need a promotion to Major or Captain Awesome Sauce :grin:

I’m curious, nothing I searched for yielded anything, aside from some oddly worded Git reports. What did you do to resolve your 1700 issue? Just manually put your fans on full? Or did you go a different route/fix? I’m hesitant to put another Linux system on here until I have something in mind to get it going. I thought maybe it was my ckb-next, because I don’t recall it happening before I installed that. But hours of research didn’t indicate this caused a problem with anyone else.

Thanks again!


Adding the second NIC completely broke the built in remote desktop / vnc thing Fedora has. Removing the second NIC did not fix that. Really weird. Super frustrating.

How do I create a bridge on my main NIC without disabling it? I added BRIDGE=br0 in the config file for the main NIC, then created a new config file called ifcfg-br0 and put in it:


After a reboot the bridge doesn’t show up.

Try removing or commenting out (append a #) that NM_CONTROLLED line. NetworkManager in F27 finally knows how to handle bridges, the libvirt documentation might be a bit out of date. Sorry about that.

Glad I can help!

I just used the motherboard’s (X370 Taichi) fan control solution. It just took a lot more rebooting than I was happy with.

I’m hoping this will be solved shortly, but I can’t say for sure that it will ever get attention. :frowning:

No worries. The bridge shows up, but when I select it for the VM it it’s labeled as Bridge br0: Empty bridge. I don’t get network connectivity in the VM.

EDIT: Never mind, file names and device names were screwed up somehow. The bridge gets an IP, but the main NIC does not. This does not work, as the NFS share is reliant on the server IP, along with other stuff like Plex and SSH.

So I don’t have a problem yet but asking preemptively.

So I am running Fedora 26 and my current PC has an Nvidia card I found a RX470 in a used PC and it works.

Do I need to do anything when I go over to the AMD card (like uninstalling the prapiatry driver for the Nvidia card), or should it just work and I can just add the radeon sittings to my /etc/X11/xorg.conf.d folder like tearfree?

Man, I don’t know wtf happened… It’s so much worse now :frowning:

I’ve done clean installs, and as soon as I get my software and settings 100%, I am plagued with issues. gdm takes 2 to 5 minutes to stop some uid process upon reboot, and when I wake the computer the keyboard and/or mouse stops working. Unplugging or swapping ports doesn’t work, I have to completely power off the machine.

I guess I’m going to have to go back to using VMs for related tasks. :confused: Not the end of the world, but I built this Ryzen rig for Unix programming. I just don’t have time to troubleshoot anymore. I’ve lost two days.

Thanks again for your help. I’ll keep you updated if I throw Linux bare metal back on here.

I can’t explain this.

Some of this sounds like it could be coming from either a bad motherboard or bad power.

What blows my mind is that a very similar setup works fine for me.

Can you post full system specs? (or if you’ve got a build log, linkey link)

I know that feeling. That’s why I’ve got a laptop that work paid for.

It’s very odd, because the same ports work sometimes. I swapped keyboards from the Corsair R95 to R30 and the issue still occurred. Now that I think about it, I don’t know if I disabled sleep or not, which is what I usually do. My three main problems:

  • Insanely long reboots. gdm is attempting to stop some process for 1 min 30 sec. Once it hits 1 min 30 sec, it resets to 2 minutes. When it hits 2 minutes, it goes to 3 min 30 sec… On and on. I usually just manually power it off around the 7 minute mark.

  • Keyboard or mouse not functioning at boot, unlocking/waking computer. Sometimes keyboard AND mouse are not functional. I have to plug in a different keyboard. Thank God I’m a tech with 100s laying around lol.

  • Sometimes waking computer from lock, all screens are black. Half the time I can control + alt + F2 into a console, other times I just have to hold down the power and shutdown.

  • A handful of minor, petty issues that don’t seem relevant to these other problems. All of the above has happened on MATE, Gnome, XFCE, and i3wm.


CPU: AMD Ryzen 7 1800X with be quiet! Dark Rock Pro 3

Motherboard: Asus PRIME X370 PRO

RAM: Corsair Vengeance LPX 32GB 3000

SSD: Samsung 960 PRO 512GB

GPU: EVGA NVidia GTX 970 4GB

PSU: Corsair 850W

Everything except the GPU is brand new. I replaced the 970 with a 1080TI in my “big rig”, so I decided to save some money and put the 970 in the Ryzen build since I wasn’t going to do anything insane graphic wise.

hello !
Quick question about systemd overwrite stuff …
I try to add a ExecStartPre to the ssh.service.
i tried, both with systemctl edit and manualy, to add this to /etc/systemd/system/sshd.service.d/override.conf


After a daemon-reload, it didn’t do anything. a systemctl cat ssh show no modification, and the script isn’t run.
systemd-delta does show [EXTENDED] /etc/systemd/system/sshd.service -> /etc/systemd/system/sshd.service.d/override.conf ; So i know it should read the file
Why did i messed up ?

Anyone have any issue with text highlighting in Nautilus, for instance when renaming a file or folder? No blue background on the text. Not sure if this was an update or not. Just noticed the other day, not looked into it yet other than fruitless internet search.

I noticed a typo … Script you put Scritp

which is correct?

the actual name of the script isn’t the one i wrote, this was more a filler than anything else. (i can’t make copy from my server to this workstation for security reason) but i don’t have any typo on the one in my server

ah ok. just checking

is the script executable?

When i add the ExecStartPre by hand in the service file, it work well, the only issue is that when the service is updated by the package manager, it override my change. That’s why i’m looking to use the override.conf

Things I was missing:

  1. make root the owner of tty
  2. don’t use su -

That’s it.

Why would adding a second NIC and a bridge attached to said second NIC break SSH and VNC on the primary NIC?

I love manjaro, I really do. But pacman is just the fucking worst. Is there a way to get it to understand english words? Like update and upgrade, the way apt does?


something something macvtap …

create a linux bridge and put the net device in the bridge and use that for the VMs. That should allow the VMs to talk to the hosts .