Return to

The small linux problem thread



Have you tried manually setting the resolution in xorg?


Right … here’s a not-so-fun one …

I just installed Mint 18.2 MATE on my laptop and want to put Win7 in a VM for work.
The laptop has a 1TB SSD, I want to give 50GB or so to Windows.

First attempt was with Virtualbox. Everything went well until I started the new VM and told it which .iso to load for the installation. As soon as I confirmed, the laptop completely froze.

Uninstalled virtualbox, autoremoved, purged and then installed Qemu.
When creating a virtual disk there (Create empty QCOW2 image, 50GB in my home folder) I get an error “an error occured creating the disk image: Resource temporarily unavailable”.

I’m beginning to think that there is an issue with write permissions in my home folder or something along those lines. My Google-fu is letting me down though.
Anyone have any idea how to sort this out? I’d like to have this fixed in the next 5 hours, otherwise I’ll have to wipe the SSD and do a bare metal Windows install.


I’ll try that tonight. Is the log in screen Wayland? If so, is there a way to force everything to be old school xorg?


Could it be a scheduler issue? What are you using? Maybe deadline is the best bet. IDK tho.

EDIT: Also I just found out about Kyber. Which came out last year. I’m slow. :frowning:


Double check all virtualization options are enabled in BIOS. I know permissions can be finicky with qemu and virt-manager. May have to store the image and install media elsewhere and play with permissions as sudo or root until it is right.


Only difference in settings to before is that this install is done in UEFI. There’s nothing else to set up in this one’s BIOS really.
Disabled UEFI, gonna install Mint again in Legacy to make sure. I’ll get back to this post in 10 minutes or so.


Mint being installed under legacy or UEFI shouldn’t really matter. UEFI should be fine.


In theory it shouldn’t. However I’m currently running a new Mint install (installed from the same stick), have updated it, installed Virtualbox and now the Win7 installer is launching just fine. Either there was an issue with my previous (fresh) install or UEFI really was the cause of the issue.


Weird. I guess it could have been an issue. Glad it’s working now, though.


I had to run mint in legacy as well. Except for me it wouldn’t even install properly.

No such issue with arch though.


I ignored this far too long. Now it bugs me. … Puns, I got them.

Device is a laptop, the Asus UX305C to be exact.

[Mar10 16:17] [drm] GPU HANG: ecode 9:0:0x85dffffb, in mpv/vo [5288], reason: Hang on rcs0, action: reset
[  +0.000002] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  +0.000001] [drm] Please file a _new_ bug report on against DRI -> DRM/Intel
[  +0.000001] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  +0.000000] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  +0.000001] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[  +0.000008] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[  +7.993262] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[  +8.000020] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[  +8.000021] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[Mar10 16:18] i915 0000:00:02.0: Resetting rcs0 after gpu hang

Here is the full error log.

error.txt (22.6 KB)

This happens when using chrome/chromium/brave or anything based on that chrome framework.
So far I have found several bug reports that look like this but no real answer.

… oh for fuck sake, is it this?


I fixed the corrupted log in screen by forcing it to use xorg instead of wayland. The config file is at /etc/gdm/custom.conf.


Do you have hardware acceleration turned on in the browser setting. If so, you may be running into a libdrm/mode setting issue. There are two drivers for this. There is the one that is packaged with and then there is the Mesa based one. They have their differences. Some users have better luck with one over the other.


Alright. What is the correct way to get ZFS working after a kernel update? I know the ZFS module(s) are not loading because they are built for a previous kernel version. But I cannot figure out how to build new module(s) for the new kernel.

I just tried completely uninstalling the zfs package, which appeared to remove everything zfs-related. I then reinstalled zfs, which installed all its dependencies. I noticed that the spl-dkms package was the one that seemed to set up the zfs module, and it seemed to build it for the kernel I was booted into. But upon reboot the zfs modules didn’t load. When I try to do modprobe zfs it complains that the required key is not available.

EDIT: After much fiddling and flailing about I got it fixed. Searching the exact error I was getting (about the required key not being available) led me to secure boot. I checked that and it was set to the windows one. Probably changed because I swapped the processor out (1275L v3 instead of 1220L v3) Anyway, I changed it to other OS and did another remove/install of zfs. Turns out it’s actually zfs-dkms that does the zfs modules. But now the module loads and my pool auto-mounts like normal.

Moral of the story: Probably the correct way to update ZFS after a kernel update (or at least the way that will most probably work) is to remove it and install it. It may work by just doing a reinstall of zfs-dkms, as that’s what does the module itself.


at what point should i be able to get a job that will make it tolerable to solve these monotonous problems… being poor sucks #ramen for life.


I am learning about Access Control Lists (ACL) right now. My root directory is inside a ZFS pool which mounts all datasets with noacl by default and the Arch Wiki describes that it needs to be enabled in case of /var/log/journal.

Are there any other locations where this would be ideal? Would it be a bad idea to just turn it on for the whole pool?


If you are running a debian based system and it does not work after the update/upgrade. you can do

sudo dpkg-reconfigure zfs-dkms 

That should take care of your issue. You can do this with any package in the Debian world.



The other thing you can do is manually install the dkms modules on the kernels:

sudo dkms install spl/0.6.1 -k `uname -r`
sudo dkms install zfs/0.7.4 -k `uname -r`

Obviously, you need to change the versions, but you get the idea. The -k flag specifies your kernel. You can use uname -r for a kernel that’s currently running, but you can replace that with any version of a kernel that’s installed.

Make sure you install SPL first, ZFS is dependant on it.


Running KDE, manjaro, Asus laptop, skylake, realtek audio, nothing special. I have the little speaker icon in the corner. It thinks that there is no audio device. Same goes for system settings. I also can’t use volume + / - on the keyboard which makes sense of course.

alsamixer works perfectly fine, sees the hardware, inputs/outputs, I can change volume and so on.

So… how did I fuck this up? :rofl:

And what can I do?

I ended up simply deleting the ~/.config/pulse folder, that worked.


Budgie on Solus became very unresponsive yesterday after a reboot. Hangs for about a minute on certain actions like switching workspaces. Tried reinstalling budgie sudo eopkg it --reinstall budgie-desktop which seemed to fix the problem but it has returned…

I’ll begin troubleshooting, but just want to put this out there in case someone already knows the solution.