The small linux problem thread

Okay, I’m feeling a little dumb here.

I had an unclean reboot of Ubuntu 22.04. I read that I should hit my SSD with fsck, but to make sure it isn’t mounted. I rebooted with a live CD, dropped to a terminal, and ran fsck /dev/nvme0n1p1 (which is my root drive) and it said it can’t run because it isn’t mounted. I mounted it (cautiously) and reran fsck which then warned me it would screw the partition up. So then I unmounted it again and re-ran fsck, which again refused to run because it wasn’t mounted. What am I missing here?

I just tested this on my /boot partition (bravo, not romeo) and it seemed to work as expected. I was only able to fsck when it wasn’t mounted. I wonder if the filesystem is corrupted and it is reported bad information. Also, what filesystem do you have on your root drive?

# fsck -fv /dev/nvme0n1p2 
fsck from util-linux 2.36.1
e2fsck 1.46.5 (30-Dec-2021)
/dev/nvme0n1p2 is mounted.
e2fsck: Cannot continue, aborting.

# umount -l /boot/

# fsck -fv /dev/nvme0n1p2 
fsck from util-linux 2.36.1
e2fsck 1.46.5 (30-Dec-2021)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information

         349 inodes used (1.07%, out of 32768)
           3 non-contiguous files (0.9%)
           1 non-contiguous directory (0.3%)
             # of inodes with ind/dind/tind blocks: 0/0/0
             Extent depth histogram: 341
       65278 blocks used (49.80%, out of 131072)
           0 bad blocks
           1 large file

         333 regular files
           7 directories
           0 character device files
           0 block device files
           0 fifos
           0 links
           0 symbolic links (0 fast symbolic links)
           0 sockets
------------
         340 files

# mount /boot/
1 Like

I’m using ext4. It was weird. When it was mounted, fsck said don’t do that. So I unmounted it, and then fsck said mount it. LOL!

1 Like

EXT4 does support online fsck now. It has been there for about 10 years. I would still recommend doing it offline, just add the force flag maybe?

Also, if you modify the FSTAB entry to do a scan of the drive, your init should force the scan due to dirty shutdown.

1 Like

Thank you! I think I got it, now! :slight_smile:

Turned on my living room PC with 20.04 (desktop) and it hits the boot screen okay then it just goes to black with a flashing cursor …

SSH in, check some logs, kill the display manager, run DISPLAY=:0 xrandr, etc.

I don’t know how to “check logs”

I do have a system tar.gz. from dec 7th

Moved my question here. Having some issues with desktop audio capture on manjaro. Below is what I have tried so far:

If you connect a keyboard and press ctrl+alt+F1 you should go into terminal mode. If not try F2-F8.

If this does not work use SSH and check system logs by typing dmesg and journalctl.

2 Likes

Give up on Pulse and take the plunge to Pipewire. It is well worth the effort and is very likely to work out of box.

I know this sounds like the old “Install Linux and all your Windows-related problems will just vanish!” snake oil some people used, but in this case there really is no reason to cling to pulse. Just let go already.

https://wiki.archlinux.org/title/PipeWire

https://wiki.debian.org/PipeWire

2 Likes

Oh? I had no idea about pulse vs pipe. pulse was default install. Will investigate, thanks.

Still learning Linux coming from a decade+ of windows. My main tower daily driver is linux, but I keep a separate and dedicated machine for each of window, mac, and linux and pick the right tool for the job depending what I’m working on. For example ableton runs like butter on the mac, and not at all on linux. I haven’t tried ableton thru wine yet.

I don’t really care about the platform anymore as long as I can do my work and the OS and software doesn’t get in my way.

i can’t ssh in

Do you have a way to boot from an Ubuntu install disk using the same version? You can do the Try Ubuntu option and at least get to a working environment from which to troubleshoot from.

already done

Does it not show a screen there, either?

I have a small home setup depicted by the figure below:

Can anyone determine why simply starting docker.service on the hypervisor (e.g. systemctl start docker.service) disables all access to trueNAS (web portal, ssh, ping)?

VNC’ing into the trueNAS instance shows the typical incorrectly configured interfaces prompt:

The web user interface is at:

http://0.0.0.0
https://0.0.0.0

yep, hit the live CD and been watching youtube off that.

Im thinking i just rsync my monthly backup from my home server after is install nautilus onto the liveCD (usb).

But mim not totally sure it wont just break it.

I have a backup of some files and when I need to restore some I’ll do a find command and then copy paste the location and use rclone to copy it back to where I need it.

When I want to restore several files I can sometimes get away with using “*” so I’ll get a few of them in one transfer.

Is there a nice CLI way for me to do a find or multiple find commands (or similar) and then multi select which files I then want to pass into my rclone command?

It’s a small linux problem because manually copy pasting each result I need works fine.

If I’m going to solve it myself I would use something like this

find . -type f -iname '*.mp4' | fzf -m

taken from here

and then use that to create a –files-from text file that rclone would use.

Is there a better way or some tool already created for this?

you just need to pipe the output from fzf into a file, and then use that file reference in your rclone command

find . -type f -iname '*.mp4' | fzf -m >/tmp/toclone.txt
rclone --files-from /tmp/toclone.txt
# clean up
rm /tmp/toclone.txt