Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#511

Sorry for taking a few days to get back. This system is a somewhat older Intel dual socket server board, so I wasn't sure I'd find the setting you suggested. I did not see anything resembling "QuickBoot" or "FullBoot".

The kernel that does work is 4.8.6. The other two are 4.9.10 and 4.10.14, both of which just show a black screen. The display doesn't turn off, it's just an all black screen with nothing on it. I tried removing the quiet and rhgb options, but it still does the same thing. None of the keys do anything, and I have to hard reset.

I have been attempting to go through the journalctl logs, hoping to find the point where it tried to boot one of the two kernels that don't work, but I am not successful thus far. I am still trying to learn how to go through these logs. This site has been quite helpful: link


#512

Looks like this, except more black so you can't really see anything. (not my screenshot)

https://camo.githubusercontent.com/97000813150c6956eb5ffced54e2393c460bc219/68747470733a2f2f662e636c6f75642e6769746875622e636f6d2f6173736574732f313033313836372f3334363738382f63313235303435652d396536312d313165322d386436662d3538636137323035663431612e6a7067

Unfortunately I'm running Intel® HD 4400, running on an i5 4200U inside an Acer E1-571. I'm not on it right now so I can't remember what the drivers are. The games becomes purely black and white, inclulding the menu. I tried running a few fixures, including downloading different drivers and editing the startup but nothing helped. It seemed to be a big issue for all Linux users about 3/4 years ago. I haven't tried using another distro on it yet.


#513

anyone know how i can get a window tiling application like shell tile
like this for budgie?

I know KDE and XFCE has this natively, but I like the aesthetics of budgie more

edit *
Also are there any applications that can take an entire folder of pictures and shuffle through the images as desktop backgrounds?

made the thread

edit**
Should there be a thread for questions about applications? As in a user describes what they need and can ask if there is applications that can fulfil the need?

found here


#514

Looking for a tool to monitor network traffic from the command line, what are some good tools?


#515

There are several like : netstat , nmap , tcpdump , Justniffer , ntopng , iftop
jnettop , NetHogs

and of course the wireshark tools https://www.wireshark.org/docs/man-pages/


#516

Does anyone know how to rescan for monitor changes?

I'm in debian with Awesome WM. I have a TV hooked up through HDMI but to get it to display I have to turn TV on then reboot for it to pick it up.

Anyone know how to force the refresh?


#517

Ubuntu 15.10 Wily

A lot of stuff I try and download for Ubuntu(through terminal sudo apt-get) doesn't work. I.E: DeSmume wouldn't work till 0.9.11 was released through terminal downloads. Any tips for somebody relatively new to Linux stuff? something like new easy ways to download stuff.


#518

Seems like packages are held back, so you may need to shift to a modern repo for specific software.


#519

I have a problem starting a manjaro Live image in my pc, I've tried loading to a USB flashdrive the GNOME and KDE versions, I configure the time zone, keyboard layout and language but when I select start from CD/USB/ISO both of them freeze after initiating the graphical interface and TLP services.
My specs:
Intel I5-4460
Gigabyte H97 Gaming 3
8GB RAM Hyperx DD3 1600MZ
Nvidia GTX 960 G1 Gaming


#520

Have you tried with the non-free drivers? That's a prickly point with nvidia. I use a GTX970 myself so I know the pain.


#521

/var/log/Xorg.0.log what does that file say? its a long text file but should have some hints as to what's going wrong.


#522

I selected the non-free drivers from the start and still when I choose start from ISO the startup freezes after initiating the graphical interfaces and TLP services.


#523

Add 'nomodeset' to the boot parameters


#524

I also use nload (link to man page) to get a quick overview of traffic per device with nload -m, it can also do graphs per device.


#525

I would have booted with the open display drivers to start with, then update/upgrade the system and install its optional drivers or download the latest off nvidia website.

Sometimes the built in drivers on the live iso's seem to break during install, I have encountered this myself with NVIDIA and AMD cards.


#526

Its happening again.

In attempting to install something in play on linux I get a little box instead of an actual window. In this case I am trying to install battle.net.

Help!


#527

I have a small issue where the finder window (or file explorer) I'm using on ubuntu gnome shows all of the hidden files. It didn't used to until I turned it on. But I can' seem to turn it off. De-selecting "show hidden files" does hide them, but when I close the window and open it again, it doesn't remember and shows all of the files anyway. Does anybody know how I can change it permanently to hide the hidden files?


#528

https://wiki.archlinux.org/index.php/Battle.net

AND

https://appdb.winehq.org/objectManager.php?iId=28855&sClass=version

Try installing the suggested components before attempting to install battlenet. Most things install on 32bit containers fine however 64bit containers can give you issues.

You can bypass POL installers and use winetricks on the POL containers to get around POL installer issues (I had a issue with dotnet45 not working via POL so had to bypass it via special commands in terminal).

(IF NEEDED) I think the commands are like follow:

?1?) WINEPREFIX="$HOME/.PlayOnLinux/wineprefix/" WINEARCH=win32 (or wine64) wine wineboot
2) export WINEPREFIX="$HOME/.PlayOnLinux/wineprefix/"
then
3) cd $HOME/.PlayOnLinux/wineprefix/
4) winetricks component1 component2, and it should install into the POL container.

? - You may not need this line.

You can also just load wine interface and go through the steps manually, it should install to the correct prefix. Like I said you only wanna do this if POL installer gives you issues.


#529

I believe my problem is in window drawing not in wine itself.


#530

Never mind. I found an answer and its fucking lazy coders.

"The issue is not actually wine, It is playonlinux's Wine builds being built against out of date libraries that are now incompatible at some level with what arch linux is now shipping with. My solution was to pull in wine-staging-git from the aur, Install that, Make sure you are using the System version of wine instead of 2.4-staging or whatever, And it should work at that point."

And indeed, if I use normal wine everything is perfectly fine.