The small linux problem thread

I have to say I’m kind of surprised steam doesn’t do something like this from is first attempt at getting mass Linux support. I suppose the endgame is using flatpak to manage all of steam’s game libraries, but I strongly dislike the direction software delivery on Linux is going. I think that shared libraries was one of Linux’s big strengths over Windows in the home desktop space and seeing everything turn into a gigabyte download of repeated dependencies is not something I’m thrilled to see happen across the board just for the sake of compatibility.

They did. It’s called the Steam Runtime, was based upon Ubuntu 12.04, and is a total nightmare for Valve to support, these days. Like already mentioned - Linux ecosystem is built on the idea that source is available, and if it isn’t, you need to support it yourself.

The biggest issue with the Steam Runtime is that it is in a forever state of supporting 32-bit libraries as the world is slowly but surely dropping 32 bit support. Worked fine up until Ubuntu 18.04, after that things got… Messy.

They still do. If you read the error in eel’s log you’ll see it’s still calling that.
Whether that’s still based on Ubuntu 12.04 can be doubted for obvious reasons but it is still there.
This is from a current installation:

$ pwd && ls | grep ubuntu
/home/tarulia/.steam/steam
ubuntu12_32
ubuntu12_64

Doesn’t appear to work quite as well as they thought it would though.

1 Like

These days, with VFIO and virtualisation being a thing, I’m surprised noone has had the bright idea of supporting a qemu VM with GPU passthrough. Just give the game a preconfigured set of values, set up an easy way to give it say, six dedicated CPU cores and one dedicated GPU while running or whatever, and provide a 60 MB full Linux system with all necessary support that boots in like 10 seconds or so. This would solve pretty much all backwards compatibility issues forever.

Ah well.

VFIO is way too niche to support. The idea of telling the average gamer he has to buy 2 GPUs (especially in the current market) is not exactly appealing.
And yes I know 1 GPU VFIO setups are technically possible but… c’mon.

Case in point:
I was meaning to do a VFIO setup and bought most of the parts for it (except for 2nd GPU), but never went through with it because I just can’t be bothered with the hassle. And I’d consider myself an enthusiast user.

Well, depends… Most gamers buy a K chip if they go Intel and AMD seems to do all APU on Zen 4 according to rumors, so that frees the discrete GPU to do fun stuff. Not to mention https://libvf.io

I agree it is currently a hassle, but if someone made it into a Lutris script? :thinking:

Requiring specific Intel or AMD CPUs world be a hard pass from me, particularly as it precludes a lot of high end options

You calling the Core i9 12900KS and Ryzen 9 7950X low-spec? Okay then… :slight_smile:

I said it precludes a lot of high end options, not iGPUs are exclusively on low end parts. Although that is currently the case with AMD, since you listed a part that doesn’t exist yet.

Honestly my least favourite thing about The Internet is when you say something like “three is a small number” and someone else chimes with “are you saying 2 is big?”

All Intel CPUs come with an iGPU unless you specifically go for the F options, and those only really make sense with the sub $200 options - above that, shaving $30 on the iGPU is pretty much spending dollars to save pennies.

If rumors are correct all AMD products will have APUs going forward.

Third, https://libvf.io allows to split the GPU even IF you only have one. This tech is still in the laboratory stage though.

So Linux gamers should either all have Intel CPUs or buy new AMD CPUs, motherboards and RAM in a few months and just… give up in the meantime?

A lot of high end CPUs don’t have iGPUs. In the last decade I have never owned a CPU that had integrated graphics. I have also never spent less than £700 on a CPU. It kind of doesn’t matter to me if in a few months AMD are going to have more APU options, that doesn’t help me, does it? The statement I have said three times is “it precludes a lot of high end options”, which is true. It does.

When did I ever say that? All I am saying is, theoretically you might already have a dual GPU setup. If not, in three years with a Zen 4+ or Intel Core 10+ it is all but guaranteed.

And even if you don’t have that https://libvf.io sidestep the whole issue anyway. :slightly_smiling_face:

Sure, but the specific comment you’re responding to is this

So sure, if you like that solution that’s fine; it’s not something I would use.

1 Like

I was endlessly trying to fix Nvidia drivers in Fedora with Secure Boot because it just wont work. Turns out the drivers aren’t signed hence the kernel refusing them. Now I’d rather not sign them myself because it was too much work and I certainly don’t want to sign them each time a driver releases (i know its not often, but still). So I nuked the root folder and finally put Pop_OS. No more distrohoping!

Then this happened:

2 Likes

You know, I’ve never been one to particularly rag on snaps. I’m fairly indifferent to it, as much as I favour the use of traditional package managers over snap, flatpak or appimage.

However this is really, really stupid:

~$ sudo snap remove firefox
snap "firefox" is not installed
~$ sudo apt install firefox
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
firefox is already the newest version (1:1snap1-0ubuntu2).

While I’m on the subject, may as well say a few words about why I was uninstalling the snap version of firefox in favour of Mozilla’s PPA version, having just said that I don’t generally care. Firstly the PPA install opens instantly, I don’t have to wait five seconds every time. Secondly I didn’t go through the effort of customising my Linux desktop and themes just for various apps to have their own default cursors and appearances. And thirdly KDE Plasma integrations didn’t work on the snap version. And as a nice bonus, using the Mozilla PPA instead of the Ubuntu repository meant I incidentally got a more up to date version of Thunderbird too, which is nice.

Message from [email protected] at May 14 21:10:17 ...
 kernel:[429911.076446] Uhhuh. NMI received for unknown reason 3c on CPU 8.

Message from [email protected] at May 14 21:10:17 ...
 kernel:[429911.076449] Do you have a strange power saving mode enabled?

Message from [email protected] at May 14 21:10:17 ...
 kernel:[429911.076450] Dazed and confused, but trying to continue

Got his outta nowhere in my console, the hell is going on? Here’s some information in case it’s useful.

> $ uname -ar                                                                                                                                                  
Linux debian 5.15.0-0.bpo.3-rt-amd64 #1 SMP PREEMPT_RT Debian 5.15.15-2~bpo11+1 (2022-02-03) x86_64 GNU/Linux

> $ lsb_release -a                                                                                                                                             
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 11 (bullseye)
Release:        11
Codename:       bullseye

> $ cat /proc/cpuinfo                                                                                                                                          
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 23
model           : 1
model name      : AMD Ryzen 7 1800X Eight-Core Processor
stepping        : 1
microcode       : 0x8001138
cpu MHz         : 3200.000
cache size      : 512 KB
physical id     : 0
siblings        : 16
core id         : 0
cpu cores       : 8
apicid          : 0
initial apicid  : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf rapl pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 movbe popcnt aes xsave avx f16c rdrand lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw skinit wdt tce topoext perfctr_core perfctr_nb bpext perfctr_llc mwaitx cpb hw_pstate ssbd ibpb vmmcall fsgsbase bmi1 avx2 smep bmi2 rdseed adx smap clflushopt sha_ni xsaveopt xsavec xgetbv1 xsaves clzero irperf xsaveerptr arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold avic v_vmsave_vmload vgif overflow_recov succor smca sme sev
bugs            : sysret_ss_attrs null_seg spectre_v1 spectre_v2 spec_store_bypass
bogomips        : 7198.99
TLB size        : 2560 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 43 bits physical, 48 bits virtual
power management: ts ttp tm hwpstate eff_freq_ro [13] [14]
[...]

I got this too a while back (just search in this thread). After a reboot it was gone and hasn’t come up since.

I am trying to set mate terminal as default terminal for popos. I have tried

sudo update-alternatives --config x-terminal-emulator

and manually selecting it. It did not work.

Any ideas? I also changed the priority of the terminal as well to 50.

Update: I Fixed it by removing gnome-terminal all together from x-terminal

2 Likes

mfw the most straightforward way of getting non-snap Chromium on *buntu is… to install Edge lmfao

Just installed SteamOS 3.0 on my third string desktop to try it out. It installed without too much difficulty, but I’m having issues with the Steam UI. On a 1080p 144 Hz Freesync monitor the UI elements are friggin’ huge, so much so that a lot of controls are off the right hand side or bottom of the screen. This version of SteamOS is based off Arch Linux and Wayland, so I don’t have a clue how to adjust the scaling or resolution.

Any hints?