Return to

The small linux problem thread



got it used the above quote and made a folder in my documents folder in my home directory
Thanks for the help


So I got my wife a 2nd monitor to go with her ultrawide, is there any way to lock the 2nd display to keep the same content even when she switches virtual desktops? She is running Ubuntu 14.04 LTS I believe, would need to check, cant remember if i upgraded her past that one.


I'm having some issues on Antergos KDE in i3wm.

In the browser, the time is displayed one hour behind the computer time (GMT). I can't seem to figure this out because in the KDE System Settings the time is correct, but it is not in the browser.

Any help?


Are there any work-arounds for getting audio over displayport working on ubuntu 17.04? I think amdgpu-pro drivers are only available on LTS.

....asking for a friend.


Compile Linux 4.11/12 with the DAL patches


I want to learn linux troubleshooting skills. I don't like that something happens and I have no idea of where to start figuring out what is going on. If that makes any sense.

Right now my home server will only boot off of one (fairly old) kernel. I have tried updating it twice in the past few months, and both times the updated kernel doesn't allow the system to boot correctly. All that happens is a black screen. No text, nothing. I have to manually reboot the server and select the old kernel.

Where do I start? I am sure it probably has something to do with logs, but where are the logs? And what would I be looking for in them?


You'll find the log files in /var/log/, and if you've never taken a peek in there before, the number of files and subfolders present may seem daunting, as different processes generate different log files. However, once you start poking around in there and read a few, things should start making sense.

For example, on my main rig, I can read the errors.log file with the less command to reveal that the system can't load/save the monitor's screen brightness:

less errors.log
May 17 11:46:30 localhost [    7.979480] systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0.
May 17 12:07:54 localhost [    8.328123] systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0.
errors.log (END)

This is expected because the old monitor I'm using doesn't allow for brightness adjustments "over the wire."

The most common logs to pay attention to would be messages.log, daemon.log, errors.log, and kernel.log, but you may find others of use to you depending on your system.

Also, there are utilities like dmesg -- a program that prints out messages from the kernel ring buffer -- which you can use to determine problems in your current session. Its output is usually color-coded so warnings, errors, and critical alerts are fairly easy to spot. Depending on what distro you're running, there's also the systemd journalctl command which will let you scroll through an aggregate of your system messages. journalctl -b will limit the output to everything from the last boot onward. Hope this helps.


Hey everyone, I currently can only get 2 or 3 out of 10ish usb ports to work right now on Fedora 25. I dual boot and these ports work fine in windows. Any help would be appreciated.



Running mx16. Really can't get TF2/CSS to run without being completely monochrome. I've tried a few work arounds with no luck :confused:


Your mainboard may be using USB controllers that don't have appropriate kernel drivers. Could you run lspci in a terminal and post the output?

Monochrome? That's a new one on me... What GPU and drivers are you running? Since MX16 is Debian based, have you discovered any posts about this type of problem from Debian users?


When I attempt to install things in play on linux everything ends up opening as a tiny beige rectangle, pictured above.

Uhhhhhhh wat?


POL pulls wxwidgets as a dependency, which needs gtk for proper theming/decoration function. what WM are you using? are you using it on a system that uses python3 by default?


I'm on arch and I'm an XFCE4 junkie.


Update to this. I got one thing installed and it started to do the mini beige box thing again.


I figured it out. Nvm


Is it OK to move an installation from one computer to another? I have an SSD with Fedora 25 installed, and it has been in my Lenovo T420s for the last year or so. I just got a Dell Latitude E7440, and when I popped the SSD into it everything seems to be working just fine. Does the kernel load the correct modules automatically, sort of making the installation "portable" in a way?

I know if you do that enough times with a windows installation shit gets weird. Too many drivers get installed over top of each other and it starts having problems. We have a "test hard drive" at work, and eventually windows gets borked and we have to wipe it and start over.


shouldn't be any major problems unless you change graphics drivers or had to enable services to get certain hardware to work.


Which version kernel won't boot and which distro?


It's Fedora 25 Server, with Gnome and ZFS installed. I remember having a terrible problem with either 23 or 24 when I updated the kernel and ZFS broke, so I don't update that system much.

I am not at home for the next few days, so I can't get you exact kernel versions, but I want to say that it is running either a 4.8.x or 4.9.x kernel. I updated it about a month or two ago, and again a week or two ago. Both times it did the same thing: black screen. It will only boot the old kernel, which is quite possibly the original one from initial install.


@marasm What you're describing sounds exactly like what happened with my Fedora 25 install when it tried kernel 4.10.x.

In BIOS I toggled the POST setting under "Power-on settings." I changed "QuickBoot" to "FullBoot" and the machine let me be past the kernel selection.

Maybe that will help.