Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#2124

Distro: Fedora 29
System: HP Zbook 15 G3
Video Adapter: nVidia Quadro M2000M
Video Driver: nVidia Proprietary 410.93

I am seeing small ‘hitches’ every now and then in both games and video playback, such as plex and youtube. Otherwise, everything runs fine. I could probably stand it if it happened only in games, but I can’t even watch a movie without getting super annoyed.

This is on a near fresh install (I have made some modifications to the UI such as Dash to Dock and a few other tweaks) with the noveau driver blacklisted and the proprietary driver straight from nVidia installed. I am assuming the issue is in the driver somewhere, or possibly Wayland but am unsure how to fix it. Just looking for some advice/experience.


#2125

There is a way todo it via DNF where you can still use your system but its even less supported and even kinda frowned upon


#2126

Have you tried choosing Gnome on Xorg before you log in? Nvidia and wayland is not a good idea. I think Wayland is even disabled when you install Nvidia from rpmfusion, did you specifically enable it?


#2127

I had not tried that. I turned off all of the gnome extensions that I installed and only enabled the ones I found absolutely necessary and it worked itself out, though. I’ll see if I can figure out which one it was this weekend.


#2128

I think you misunderstand, when you log in and can type your password there is a small cog you can click. There you have a menu with things like Gnome and maybe others, if you see one with Gnome on Xorg and it is not the default try that. If you don’t have that chances are you’re probably already running on Xorg. In that case have a lookt at https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting


#2129

No, I know exactly what you mean. The problem seems to have simply been a gnome tweak/extension. I was indeed running X and not Weyland. Thanks.


#2130

I have am running a VPN through the CLI, How do i list available [arguments…] for any given command?


#2131

man openvpn
openvpn --help


#2132

Looking through journalctl I noticed this shows up at least once on every boot:

dhclient[3255]: Timeout too large reducing to: 2147483646 (TIME_MAX - 1)

Is this something to be concerned about?


#2133

Is there a better way to do this?

ls ./blah/* > /dev/null 2>&1 && echo "Valid path." || echo "Invalid path."

I’d prefer to use -f or -d but I need to accommodate *.


#2134

are you getting IP addresses?


#2135

Yes. Networking works, aside from my intermittent connection issue. I was wondering if that message is indicative of a problem, and also if it might be related to my issue.


#2136

It’s not something that I would be worried about


#2137

Ever seen this?

dnf won’t autocomplete package names for my user (hangs until Ctrl-C X2), but it works if I become root.

eg. dnf info firef[TAB]

This started immediately after upgrading from Fedora 28 to 29. It’s driving me mad that I still haven’t found a solution.


#2138

lista=$( ls -d ./blah/* )
for xx in $lista ; do if test -d $xx ; then echo real ; fi ; done


#2139

Not sure if it’s related but I consistently get this error in dnfdragora when trying to access one specific transaction history on the day that I upgraded to Fedora 29.


#2140

I’m writing an rclone wrapper script (lock file, email report, etc), so I ended up going with:

rclone lsd "${source}" &> /dev/null && ...

I was already using it to validate remotes but forgot that it can do local stuff too.


#2141

Is this normal?

image


#2142

Yup. $( pwd ) is expanding to dir then sh is trying to execute the result.

Try this: $( /bin/which ls )

I think which is also a bash builtin which will show aliases.


#2143

What am I looking at here?
the pwd command prints the current working directory
$(pwd) would try to run the current directory as bash input.

I don’t know what the 126 folder is all about though