Return to

The small linux problem thread



Working on remote garage battle station- last time I physicalized a VM it was with Win10, it saw the pass-through AMD card (some super old fanless AMD) without issue and displayed- now trying with Ubuntu- the HDMI out has power (HDMI switch powers up), but Ubuntu is not displaying or showing another monitor in the console session. I take it its a driver issue- I have an nvidia but I’m pretty sure VMware will not let me pass that through.


anyone know why twitch doesn’t work on my desktop?
works on my laptop

same versions of fedora 29, firefox, only difference is that the laptop is using a nvidia mobile gpu, and desktop is using amd gpu


Try installing ffmpeg packages

$ sudo dnf install ffmpeg
Last metadata expiration check: 0:01:47 ago on Tue 08 Jan 2019 06:47:33 PM CST.
No match for argument: ffmpeg
Error: Unable to find a match

hold on

looking at this


You need rpm fusion repos first, I believe


yup ffmpeg solved the issue


Hell yeah man, anytime


mismatch in GTK2/GTK3 between nvidia-settings and system causing css theme problem?

try adding option nvidia-settings --use-gtk2

more options in man nvidia-settings


@AdminDev I need help brother :smiley:

So I have a computer with 2 lan cards 1 connected to the internet another connected to a laptop. I want to have internet on the laptop. Computer is on linux, laptop is on windows. What’s the fastest way to do it. ( I already tried a few things but I am really bad with linux so i coudn’t figure it out )


enable ip_forwarding
set the iptables FORWARD chain to accept traffic
give static IP on laptop & the port you connect laptop to on the PC
set the static IP of the PC as the default gateway on the laptop


@Yoray This is what I would recommend as well. Forward the traffic to the laptop. Linux functions very well as a router (though not as good as FreeBSD :wink: :wink: :wink: )


Thanks for the quick answer.

I did step 1, 3 and 4 in an instant. It took me some time to figure out how to do step 2 with Firewalld :smiley:


Glad you got it working.

one more thing…

ewww /s


yeah I read how to use iptables and read one line that made me consider just finding out how to work with firewalld -

-iptables is targeted towards system administrators. openSUSE users should use the Yast Firewall module to configure and control the firewall.

I aint no Sys Admin



I just installed Ubuntu on my HP Envy x360 (finally let me actually do it for a while I just couldn’t install on this computer) and I noticed a distinct difference in audio quality from the speakers. it’s quieter and way way more tinny. plugging headphones in it sounds just fine, exactly what i’d expect. but with the speakers it’s like the base disappeared. any ideas on how to fix that?


It’s possible that the OEM had an audio filter on their driver for windows, especially if its one of the laptops with beats. But that doesn’t explain why it’s quiet. My recommendation to fix the quality of the audio is try installing pulseaudio-equalizer, which will let you play with your bass and treble.

I was able to find this post from years ago about beats audio on HP laptops, the fix is the OP


I have been trying to set up a basic http site with nginx. Soft linking the site config from sites-available to sites enabled is not taking effect, but using a hard link works.

Is there any problem with using ln instead of ln -s to add it to sites-enabled?


I don’t think that hard linking should be a problem. If its something you’re worried about I would suggest checking the logs when you have it soft linked.


Thanks, I thought it was alright, just everyone uses soft links and I did not know if there was a reason for that.