Return to

The small linux problem thread



You can be whatever you want as long as this damn computer reboots in the fraction of a second it’s supposed to :stuck_out_tongue_winking_eye:


edit the .service file for the offending process. You can find its location with systemctl status <servicename>
Add or edit under the [Service] section and add or edit TimeoutSec= to your desired value.


Awesome, I was close, was poking around for the location.

Thank you! Going to see if this works. <3


Out of curiostity, what is the service causing problems? In some cases it may be worthwile to figure out why it’s stalling if it’s something important.


On startup it’s dhcpcd. Shutdown it’s either GDM or ckb-next.

Weird, because on Debian Stretch, Fedora, and Arch I didn’t have this issue. Same workstation.


dhcpcd could be freaking out because of some network configuration. I don’t know about ckb-next (some RGB thing?) or gdm as I don’t use either.


Exactly :joy:

Although, I use it for Purple.

I’ll take a look at the server setup. I have a separate DNS and DHCP server that might have some weird config I missed.

If it is Gnome, that’s concerning, especially considering that’s what they’re shipping with now :thinking:


If I leave SDDM running long enough without logging in, it hard-locks :joy:


Lol well, I feel a bit better then :wink::laughing:


It takes about an hour, but it’s definately happened to me multiple times.


So, wtf happened to CentOS?

1810 image does this out of the box, can’t even load the installer. 1804 and 1704 will let me install and run yum update, but does this upon reboot.

It also POWERS OFF my server.

This did not happen prior to 1810. Also, it is not my USB or my server: Ubuntu 18.04 server, FreeBSD, Debian, and Hyper-V all install and function as hypervisors.

The 1810 image is fully bootable and functional as a VM.

Wonder what changed about my hardware?

I guess I’ll stick with Ubuntu, but its network stack sucks.

Checked Fedora, no issues so far.


Aint mok responsible for the uefi keys? Yeah it won’t boot unless secure boot (or sometimes TPM) is disabled, so might be worth disabling it and enrolling the appropriate keys.
Unless malware, but unlikely.


Hm… That’s really interesting and something I’ve not considered. Nor did my quick and dirty research suggest. I’ll see if either of those are enabled and try disabling to see if that has an effect.

TPM was off and there isn’t a secure boot option.

Oh well, thanks anyway.


was it systemd-analyze blame ?


Ahhh. Yes. That was the command to see the time that a process is using during boot.


Is there a version of that showing what process is taking a long time to shutdown, because that would be relevant.


was relevant to question quoted
may have identified something systemd related, but not everything starting up

journalctl -rb -1

to print journal of the last boot in reverse chronological order


Any ideas why my VFIO script isn’t being found during bootup? I’m getting a message when Kubuntu boots that says /usr/bin/ not found but when I navigate to /usr/bin there is a which contains the proper script.

Is /usr/bin/ just not accessible during boot? If so, where should I put the file?


I fought the boot manager and the boot manager won. The Clash have nothing on me.

Am trying to remove Microsoft’s boot managers from my drive. They smell bad and carry diseases.
Used the efiboot to remove said offensive entries, washed my PC with bleach and re-generated my grub file. All well?
No, it makes a new…new boot manager… so i did it again, same thing. Googled some more, apparently it’s because the actual folder still exists, so grub will ‘read’ it anyway.

I can’t delete that damn folder, lol, help me:

[[email protected] EFI]# chown -R max u+rwx /boot/efi/EFI/Microsoft
chown: cannot access ‘u+rwx’: No such file or directory
chown: changing ownership of ‘/boot/efi/EFI/Microsoft/Boot/bootmgfw.efi/grubx64.efi’: Operation not permitted
chown: changing ownership of ‘/boot/efi/EFI/Microsoft/Boot/bootmgfw.efi’: Operation not permitted
chown: changing ownership of ‘/boot/efi/EFI/Microsoft/Boot’: Operation not permitted
chown: changing ownership of ‘/boot/efi/EFI/Microsoft’: Operation not permitted

Edit: Am new and clueless. No heavy sorcery please and always type in old fart-compatible English. Thans ^^
Edit 2: It’s fat-32 format is why… OK, more googleing…


So I’m trying to open Nvidia-Settings and this is what I get from it.

[[email protected] ~]$ nvidia-settings

(nvidia-settings:1722): Gtk-WARNING **: 23:35:03.394: Theme parsing error: gtk.css:3611:22: 'none' is not a valid color name

ERROR: Unable to load info from any available system

[[email protected] ~]$ 

But I have bumblebee and everything properly installed. I’m not exactly sure what to do.

And theres no GPU options in bios. Its just what I got here.

Help pls