The small linux problem thread

I have am running a VPN through the CLI, How do i list available [arguments…] for any given command?

man openvpn
openvpn --help

Looking through journalctl I noticed this shows up at least once on every boot:

dhclient[3255]: Timeout too large reducing to: 2147483646 (TIME_MAX - 1)

Is this something to be concerned about?

Is there a better way to do this?

ls ./blah/* > /dev/null 2>&1 && echo "Valid path." || echo "Invalid path."

I’d prefer to use -f or -d but I need to accommodate *.

are you getting IP addresses?

Yes. Networking works, aside from my intermittent connection issue. I was wondering if that message is indicative of a problem, and also if it might be related to my issue.

It’s not something that I would be worried about

1 Like

Ever seen this?

dnf won’t autocomplete package names for my user (hangs until Ctrl-C X2), but it works if I become root.

eg. dnf info firef[TAB]

This started immediately after upgrading from Fedora 28 to 29. It’s driving me mad that I still haven’t found a solution.

lista=$( ls -d ./blah/* )
for xx in $lista ; do if test -d $xx ; then echo real ; fi ; done

1 Like

Not sure if it’s related but I consistently get this error in dnfdragora when trying to access one specific transaction history on the day that I upgraded to Fedora 29.

I’m writing an rclone wrapper script (lock file, email report, etc), so I ended up going with:

rclone lsd "${source}" &> /dev/null && ...

I was already using it to validate remotes but forgot that it can do local stuff too.

Is this normal?


Yup. $( pwd ) is expanding to dir then sh is trying to execute the result.

Try this: $( /bin/which ls )

I think which is also a bash builtin which will show aliases.

What am I looking at here?
the pwd command prints the current working directory
$(pwd) would try to run the current directory as bash input.

I don’t know what the 126 folder is all about though

its the return status $?

1 Like

Yep that’t it, he has exit code in is $PS1


Yeah, it makes sense now. I’ve been staring at this too long.

Here’s one that is getting frustrating…

[ ${__ABORT} -eq 1 ] &&
echo ${__ABORT} &&
debug "Backup was aborted. Compiling report."

is generating:

2019/02/17 00:45:37 DEBUG : Backup was aborted. Compiling report.

I have a problem with switching my audio adapters in Fedora 29. I have headphones plugged in the front I/O of my case and the speakers in the MB at the back. I only get audio from the headphones. I switch to the other adapter inside the audio settings and silence.
Edit to add: on windows I just click on the speaker next to the clock and choose the output. In fedora, this isn’t the case.

On my main machine man -k doesn’t seem to work, man -K works but is not the same

command taken from the man manpage

$ man -k printf
printf: nothing appropriate.

just doing man printf gives the expected result


OS: Arch Linux
Kernel: x86_64 Linux 4.20.8-arch1-1-ARCH
Uptime: 34m
Packages: 1284
Shell: bash 5.0.0
Resolution: 4480x1440
WM: i3
GTK Theme: deepin [GTK2/3]
Icon Theme: deepin
CPU: Intel Core i7-4770K @ 8x 3.9GHz [27.8°C]
GPU: GeForce GTX 970
RAM: 2753MiB / 15988MiB

For some reason i didn’t think about searching for man -k nothing appropriate, after doing that i found an answear, sorry for posting this

What shell are you using?
Shouldn’t that be (for bash):

if [ ${__ABORT} -eq 1 ]; then
echo ${__ABORT} 
debug "Backup was aborted. Compiling report."