The small linux problem thread

Yup, that did the trick. Dependency is okay now and fre:ac opens when I double-click it. Thank You!


No problem. Glad to help :smiley:


had a pgp keyring issue from not updating my laptop for a week, solved it with

wanted to post this for if I run into the same issue in the future

s: signature from Antergos Build Server (Automated Package Build System) <[email protected]> is invalid 
:: File /var/cache/pacman/pkg/antergos-desktop-settings-1.7-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)). 
Do you want to delete it? [Y/n] 
error: failed to commit transaction (invalid or corrupted package) Errors occurred, no packages were upgraded.

use this

sudo pacman -Scc
sudo pacman-key --refresh-keys
sudo pacman -Syu

You occasionally get this with pacman distros regardless of the update frequency. It’s not about update frequency but key expiry.

But yes, that is the correct method to repair the keystore.


found my solution, just posting it here so that I can reference back to it should I need to reinstall discord
discord throws this error when installing it


==> Verifying source file signatures with gpg...llvm-6.0.0.src.tar.xz ... 
FAILED (unknown public key 0FC3042E345AD05D)libcxx-6.0.0.src.tar.xz ... 
FAILED (unknown public key 0FC3042E345AD05D)libcxxabi-6.0.0.src.tar.xz ... 
FAILED (unknown public key 0FC3042E345AD05D)

solution is to use

gpg --recv-keys 0FC3042E345AD05D 8F0871F202119294

should solve the gpg key issue

1 Like

Apologies for the imposter BSD post.

Does anyone know the breakdown of FreeBSD’s versioning?

For example:

FreeBSD 11.1-RELEASE #0 r321309

What is #0 r243825?

This appears in sysctl kern.version (so also in uname -a or uname -v).

I’m mainly looking for the revision number or rough equivalent. Not sure to go with r243825 or 1101001 from sysctl kern.reldate or if those correspond. And no idea how the #0 factors in.

I know FreeBSD also previously listed a patch number after RELEASE (ex: FreeBSD 9.2-RELEASE-p4 #0), but I don’t know if they’re still doing that or what.


Distro installs last ~2 days, then login loop.

Ryzen 7 1700x

I have to install 'buntu flavored distros using nomodeset, boot once with nomodeset, then install Nvidia proprietary drivers. No problem there. Install runs perfectly for a few days, then after restarting I get login loops. This happens on Pop OS, 'Buntu, etc.

Problem doesn’t happen using Fedora, but I likely my debian based distros. Any thoughts?

Things I’ve tried (in CTRL+F4 terminal)
tweaking .Xauthority
apt upgrade/apt dist-upgrade
updating Nvidia driver (already current)
installing LightDM (which works to log in but causes new problems, since I usually use gnome or cinnamon)

sounds like the nvidia driver shitting over wayland. Can you confirm whether or not the login loops happen with nomodeset

Will be home soon to check and let you know.

Try vanilla Debian. I personally run Debian SID/Unstable as my daily. Come to the “right” side.

My Asus G50VT-X5 is being bitchy. It has a 9800M GS and after I install an OS and install NV 340xx the desktop will just freeze. IDEK what to do about it or look for.

Having never used debian, didn’t even see how to boot with nomodeset. Trying 'buntu 18.10 beta now Dje4321, With Nvidia 390 installed, set apt-hold for Nvidia-390 (not in front of it right now to get the name right) and we’ll see if it was an Nvidia driver update breaking things.


Blacklisted nouveau, that didn’t do shit. Seems to happen when I open chrome… Lets try firefox :U

ok it doesn’t seem to matter what I open it just freezes after a few minutes. I can still move my mouse though.

I dunno what to do now I can’t think what is wrong and journalctl doesn’t say anything useful.

Picture of journalctl

This i- what it says as its frozen.

Is this a random lockup after a while or are you unable to get to the display manager?

Aaahhh, I’ve been actually struggling with the same thing on Fedora, but I’m on a 10 series with NV 390. Firefox is my primary browser and it happens with firefox. I’m thinking it’s either a powermanagement thing or an interrupt issue.

This is in deepin.

…Well fuck thats not exactly exciting to hear. And I just have 340.106, I’m not even close to the newest drivers…

Well fuck now what do I do.

I don’t know. I’ve been living with it. It’s one of those things that happens once a day for me.

nouveau didn’t have the problem, so if you don’t need full performance for the time being, switching to them would be my recommendation. I’ll definitely keep you appraised if I make any progress though. It’s been a 2-3 month struggle.

Only reason I need proprietary drivers is for the L1KVM. nouveau doesn’t like it.

1 Like

I need a laptop to play TF2 on till my Oryx gets here D: aww man

Ah, I get that.

I’ll keep digging into this.

EDIT: Are you able to switch to a TTY after the freeze?

1 Like

Nope… Not at all. Most I can do is have a terminal open at the driver crash.

Maybe its a gnome thing? Are you on gnome? Deepin is built on top of gnome… Chris from JB has this happen constantly.

1 Like