Return to Level1Techs.com

The small BSD problem thread

#21

Yay, I actually have a BSD related question. Sort of. I know nothing about BSD. I installed FreeNAS just to try it out. I tried it several years ago and didn’t like it. I’ve been running Fedora with ZFSonLinux since then, but I wanted to try something new.

On that Fedora system the ZFS pool was always degraded because a disk had “too many errors.” I could never really determine if the disk was actually bad because SMART said it was fine.

Anyway, since I installed FreeNAS, whenever I cold boot the server, and all the drives spin up from being off, I see this:

I’m assuming that drive is the one Fedora/ZFSonLinux was complaining about. Again, SMART says all the drives are fine. I ran a long test on them all.

Is there a way to match that device ID to a drive once FreeNAS is running?

1 Like

#22

There isn’t a device ID shown in the error, but try mpsutil show devices.
The error itself is coming from the HBA trying to get an ID from a device and failing.
The command might tell you which device is causing problems by process of elimination.

3 Likes

#23

I don’t have a problem, yet, but I am curious about ZFS and two drives of different speeds. The size is the same, 256 that equates to 224. But the speeds are off by 100 Mbps or so, on most benchmarks.

I’m curious if a RAID1 will cause issues with this. I’ve read conflicting answers, but most answers have suggested that this isn’t a major issue.

1 Like

#24

Welp. Just unplugged and replugged all eight SATA connectors into the two hotswap cages, both 8087 connectors to the HBA card, and removed and reinstalled all eight drives one at a time.

No more error. Guess I don’t have a small BSD problem. Now on to making the pool.

2 Likes

#25

You probably won’t get very consistent performance, but it’s not going to break anything.

3 Likes

#26

Thanks!

Would it be better to just create two separate pools at RAID0 for each drive?

1 Like

#27

okay, so i got my omniOS VM going but im not sure how to get networking going:

ping 8.8.8.8
returns 8.8.8.8 is alive

but pfexec pkg refresh return
unable to contact valid package repository
encountered the following error(s)
unable to contact an configured publishers
framework error: code: E_MULTI_UNKNOWN_OPTION Could not resolve host

any idea where to edit something to get pkg going?

oh yeah: macbook is on wifi and the vm is on via vmware with network adapter bridged adapter on en0 wifi

okay, so what am i missing?

so i can resolve the hostname no problem with dig but when pkg gets at it, it cant resolve the hostname.


seems like this is the root problem:

anybody an idea how get that going? i have google dns’ in /etc/resolv.conf

[SOLVED]

add 2 network adapter in virtual box: bridged adapt bridge0 and bridget adapter en0: WiFi

worsk like a charm. Oh, and add some nameservers ( like google) to /etc/resolve.conf (or create and then add if it doesnt exist)

2 Likes

#28

I’m trying to install Gnome on rpi3b+ using pkg but it’s giving me libssl.so.8 not found, required by "pkg"
I reinstalled pkg several times and it still doesn’t work. Any ideas?

1 Like

#29

How?

Via

pkg-static install -f pkg pkg upgrade -f

Sauce: https://forums.freebsd.org/threads/i-cant-upgrade-pkg-after-upgrading-11-2-to-12-0.68717/

2 Likes

#30

Exactly this way.

2 Likes

#31

Back to googling I go

1 Like

#32

You and me both. I saw on one forum that it was recommended to install all ports, so now I’ve run portsnap fetch and it’s currently verifying

3 Likes

#33

Yeah, I also see that compiling from sauce is one of the recommended fixes.

3 Likes

#34

Oh, god this is annoying…I’m gonna make food, eat and watch a movie

3 Likes

#35

:joy:

Enjoy the movie

3 Likes

#36

You do not have to be dealing with ports to install packages!

1 Like

#37

Learned this the hard way several months ago :joy:

1 Like

#38

What did you do before this?

0 Likes

#39

The FreeBSD handbook.

https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/

edit:
beaten. but definitely, the handbook is great.

2 Likes

#40

Honestly, not much. I wanted to install a desktop environment, but failed miserably straight from the start :stuck_out_tongue:
I don’t remember exactly which commands I used. I tried using history, but I think I had to have had it setup beforehand?
A feature I’m missing is resetting the os to defaults. Like, as they were when the image was installed. I know there are dump and restore commands but they require restore points. What I mean is I wish there was a command that just reset everything back to defaults without me having to do much premeditation :stuck_out_tongue:

2 Likes