Return to Level1Techs.com

The Level1Techs KVM (Keyboard, Video Mouse) Switch - 4k/60hz monitor & USB Switchbox | Level One Techs


#221

Huh, I didn’t think that could be it since I would lose signal if I switched off while I was on the BIOS or grub screen. I was using an older Gentoo LiveDVD since the newer ones can’t boot from UEFI.

I swithced to a newer Ubuntu Live CD and I can switch and and fourth fine (so long as the system is booted and not on the Grub screen). That should be good though. Thanks. :slight_smile:


#222

@djsumdog and @wendell I seem to have the exact same problem but on a Windows7 box. Same Graphics card (Gigabyte rx550) and same behavior. If I boot the box while that output is selected in my KVM, then no problem. The second that I go over to another system and then try to go back to the system in question, no output, monitor goes to sleep. Any further ideas on this?


#223

I had problems with this on my Fury. Does your display support MST? If so, disable it in the OSD. That mostly fixed it in my system. Additionally, you should make sure you’re running the latest drivers from AMD.


#224

@sgtawesomesauce I looked in my on screen display and could not find any mention of MST unfortunately. I’ll have to check on the driver situation. Thanks for the response!


#225

Any time. Just to be clear, you’re on Windows, not Linux?

If you move the mouse, hammer on the keyboard, etc… after it’s booted into Windows, you still aren’t able to get it to wake up?

What happens if you switch back and forth a few times? I’ve had success with that as well.


Regarding your hardware setup, What’s the total run length of the cables? Do you have any display corruption with the cables during successful operation? Do you encounter any problems with the display(s) without using the KVM?

I’m kinda grasping, but the more I know about the setup, the more I can help.


#226

Yes the system that this is occurring with is a Windows 7 Box, Threadripper 1920x, Asrock Fatal1ty x399 Board and a Gigabyte RX550. I know Windows 7 on Threadripper is a little unorthodox, but I would like to duel boot the box in the future with a linux distro and avoid the upgrade(downgrade) to Windows 10

Moving the mouse and hammering the keyboard do not wake it back up. I have not tried switching boxes on the KVM while it was booting or in UEFI. The problem, as I know it, is only after being fully booted.

I have tried switching back and forth a few times and no dice. I’ve used both the hardware switches on the KVM as well as the hotkeys too. I’ve also tried unplugging the DP cable and re-plugging it in and also nothing. One weird caveat is that I have had it work successfully once or twice, but only after an extended period of time before switching back to the box.

The other box I have is also a Windows 7 Box with an RX480 in it and Haven’t had any problems bringing that box up on the KVM switch.

My cable length is 10ft, however, I have zero problems when not using the KVM and never had any artifact issues or display corruption.

I’m gunna have look at the driver situation and make sure that everything is working there before anything else.


#227

It’s really not that bad. In fact, I enjoy windows 10 over windows 7. And this is coming from a Linux zealot.

I wonder if this is a Windows only thing. Have you tried booting a linux distro?

Hardware switches and hotkeys are functionally the same. Shouldn’t make a difference.

Hmmm, I’ve encountered something similar:

  1. switch to known good system
  2. switch to problematic system, blank screen, sleep mode
  3. switch back to known good, wait 30 seconds or so
  4. switch to problematic system, get lock screen

something like that? Might be a display incompatibility…

Total run GPU -> KVM -> monitor? If so, you’re probably good. I think Wendell mentioned anything over 4m (12ft) is problematic.

Good good. This suggests it may not be the cables, although, do you know the brand of cable?

For sure. I’m off for the night.


#228

That’s another good suggestion. I’ll look into the driver situation and also attempt a LIVE USB boot of Ubuntu or Mint and see if that helps.

I figured they functioned the same but generally I just try random stuff when diagnosing a problem to see if there’s some weird work around.

Total run is more like 15 feet then. I didn’t account for the length between the KVM and monitor. Can’t recall the brand of the cable and there’s no obvious markings on it.

Indeed it’s late/early. Time to sleep. I’ll get back after I’ve tried some more stuff and let you know how it went.


#229

Ruling out hardware is usually one of the best starting points.


#230

Afaik software updates resolved the other rx550 issues. Try shorter cables as there is no repeater in the kvm it’s just passive. A repeater would add latency.

Try other outputs on the rx550 as well. The rx550 seems to have a weaker out put than e.g. rx480 but afaik everyone got their 550s working with some fiddling


#231

@wendell and @sgtawesomesauce

I think I solved it:

Step 1. Update your graphics driver
Step 2. No more problem.

Thanks to everyone for your help. What a great community!


#232

Glad to hear it!


#233

So, I’m encountering a new, curious, minor issue.

When returning from sleep in Windows 10, on my Fury, the primary monitor wakes up and displays properly, but the secondary doesn’t. The mouse moves across the edge of the primary over to the secondary in such a way that it implies that Windows thinks the monitor is connected, but the monitor isn’t receiving a signal.

Switching display inputs, waiting a couple seconds to hear the windows “device unplug” sound, and switching back solves the problem.

I’m not that inconvenienced by the problem, but I thought it would be worth reporting.


#234

I’ve been having a similar issue. Sometimes I don’t even need to switch - just messing with resolution or other settings (e.g. refresh rate) causes the display to say it’s not receiving a signal while I can see that the operating system (both windows and Linux had this issue for me) sees it as connected. I’ve been assuming it’s a display issue, since unplugging it from power and plugging it back in seems to fix it, and the order of the cables doesn’t matter. I’ve been trying to see if I can borrow a display from someone to try and see if it has the same issue, and then go from there. Could be that the display isn’t broken per se, but implements the DP protocol in some erroneous way, and thus gets into a bad state until restart / enough fiddling.


#235

Hmm… What gpu do you have? I wonder if it’s a gpu issue…


#236

I would be skeptical of a GPU issue, since this happens for me on two different machines with different GPUs (one has a 1080 ti, and one has an Intel HD Graphics 620 integrated GPU).


#237

Hmmm… Do your monitors support MST? I had issues with that and disabling it helped a lot.


#238

My monitors don’t support MST, although the laptop is connecting to them via a dock which uses MST. The windows machine, however, connects to them directly, no MST in the middle.


#239

Two quick questions:

  1. Are the keyboard shortcuts or KVM PDF posted anywhere? Maybe you should add a support link to the store. I think I might have disabled the beep/HID stuff by accident as I no longer hear a beep when switching and my little HP server seens to longer accept HID input. I know I have my instructions with all the shortcuts somewhere but I can’t seem to find it.

  2. So I had this problem with both my current desktop running the Radeon RX550 I mentioned earlier, as well as my older Dell XPS 15 with Intel integrated connected over USB-C to DisplayPort: If I wake up the screen from idle, I get no signal. I usually have to switch to my Windows 10 box, and then back to my Linux box to see my screen again.

A hack is to drop the screen resolution and bring it back up, and that will usually get me my signal back. (I use i3 for my window manager, so it doesn’t screw up any of my windows. Tiling window managers for the win!).

I have to do this at work to get my MacBook to wake up the external USB-C display attached to it (the MacBook runs Gentoo, because I’m insane like that), but it seems kinda hacky. (I modified the source code for xssstart to cycle the resolution down/up automatically when the screen wakes)

On the Mac, I got log message like the following:

[13221.797955] [drm:amdgpu_atombios_dp_link_train [amdgpu]] *ERROR* channel eq failed: 5 tries
[13221.797971] [drm:amdgpu_atombios_dp_link_train [amdgpu]] *ERROR* channel eq failed

but I don’t see anything like that my kernel or Xorg logs on this Linux box.

To be fair, I had this same issue with the Dell XPS 15 and my old IO Gear KVM. I’d have to switch to another box on that KVM occasionally too after the Linux box entered sleep mode on the monitor.

Versions:

Kernel: 4.14.52-gentoo
AMDGPU driver: xf86-video-amdgpu-18.0.1
xorg-server-1.19.5-r2


#240

This PDF has most of them. It’s not the exact same, but it’s definitely close.

Lots of those adapters are not great. @wendell has done some testing on them. He can probably give you more insight.