Return to Level1Techs.com

The AMDGPU Info/News Thread

linux
helpdesk

#508

So, for some reason, installing amdgpu-pro 17.10 on ubuntu 16.04.2 results in x crashing when it boots for me. I am running a custom kernel 4.8.17 (only customized option is enabling sea islands amdgpu support). I am running an 8gb R9 390. I will point out I installed with the --compute flag. However, before, when I installed full, it still had the same not booting problem. Didn't check it's other behaviour then though.

What my screen looks like on boot

Integrated graphics?

Interestingly, it has also broken the intel graphics, even if I set my motherboard to not use my gpu, and only use the igpu. When I do that, it at least shows the gnome splash screen, but then drops me to a terminal.)

Ethminer, when I ran it's benchmark, just threw errors at start, then gets stuck on trial 5.

lspci -v output

If I run startx, the system starts asking all funky. (terminal line starts in random spots, terminal doesn't show what I have typed until I press enter


Xorg.1.log pastebin

https://pastebin.com/ybiY3kNC

Oh,apparently while I write this it won't wake up from sleep. Great. Will edit in more troubleshooting details in a bit.

Help trying to find a download for amdgpu 16.60 would be appreciated. As that is what ethOS uses, I have a feeling, that maybe that would work. Can't find a link for older downloads on amd's site though, or anywhere else for that matter.


#509

Nope. It is pretty automated. The application just pulls the ready kernel packages.


#510

okay cool. then I'll try mint with the 4.12 kernel as soon as I can. thx.


#511

AMD slides on the radeon software. Specifically interesting that they advertise the Open Source a stack on their performance slides and the fact that the profiler has Vulkan and Linux support.


The Wayland Discussion/News Thread
#512

Mint has a shit default policy. update your kernel to the latest stable they offer.


#513

I use arch dude I’m not gunna use that garbo.

Anyways, the windows drivers are built on top of the linux drivers. Its all a complete base. Neat that its all in the slides now.


#514

Could it be that amdgpu has seen some pretty big improvements with the some kernel update lately? Either that, or it’s because I had to reinstall arch, but suddenly borderlands 2 is actually playable. Because I used to get like 100+ fps, but it would be very inconsistent with a lot of stuttering, but now its 100+ with no stuttering and buttery smooth gameplay. I’m happy!


#515

Its because devs are working with linux more and more as masses of people abandon windows. A fair chunk of users quit after the forced 10 bullshit, and now it looks like 10 S may be the next upgrade so hopefully devs start giving a fuck about opengl soon or they’re fucked.


#516

AMDGPU is finally at the point where they are optimizing for real world use cases rather than playing catch-up with OpenGL. Could very well be that they took a look at borderlands recently.


#517

Or better yet, Vulkan.


#518

Or both. More likely OGL though. Vulkan is seen as another mantle :\


#519

OpenGL is seen as the failure it is. Implementations are inconsistent, uncompliant and take loads of developer time. Even Khronos appears to have lost interest in OpenGL.

Vulkan is seeing adoption in more and more game engines and tools with apple being the most notable exception. In addition it also provides full-fledged compute capabilities with Khronos even considering a merger with OpenCL.

There was nothing wrong with Mantle’s concept, but rather that there were too few companies behind it. That’s not true for Vulkan either.


#520

That is more than considered, that is the plan.

http://www.pcper.com/reviews/General-Tech/Breaking-OpenCL-Merging-Roadmap-Vulkan


#521

I’m looking at installing AMDGPU-PRO for potential game benefits with my 580. Can anyone confirm that PRO helps?


#522

Pro doesn’t help with gmaes


#523

Fuck then I need MOAR THREEDS


#524

If anyone has Vega, please post performance stuff or PM me and I’ll send you what I would like to see from benchmarks being done.


#525

I recently installed amdgpu-pro on Ubuntu 16.04 to drive an RX560. Everything appears to be working correctly, but I don’t get HDMI audio. The HDMI audio device shows up in pulseaudio/alsamixer/etc, but if I switch to it as an output I don’t hear anything. Has anyone else had similar issues? I switched to amdgpu-pro specifically to get HDMI audio working as I’d heard it wasn’t yet supported in amdgpu opensource stack, but still no luck…


#526

I just use a soundcard :T

There a reason you need HDMI audio?


#527

HDMI Audio will come with the Display code (also known as DC, DAL) that has yet to be mainlined into the linux kernel.
It won’t be in 4.14. So we can hope for 4.15, but we have been hoping for it being in the next kernel release since 4.9…