Return to

The AMDGPU Info/News Thread



My fedora 25 install - Boarderlands 2 runs fine.


Speaking of borderlands 2, I've got this weird problem with that game (dont know if it affects other games as well but borderlands 2 is my linux test game), where the better the driver the gets, the less consistent my fps, meaning it still doesnt feel very smooth. So with catalyst, my fury x barely did 60 fps, then with the first version of amdgpu (on kernel 4.2 or 4.3) it ran slighty better but slightly less consistent and this problem got worse over time. Now its at the point where I have to put a frame cap in to actually play with the pro driver and the game just feels like complete ass on mesa even withe frame cap. Anyone else have this issue?


jNo thats what I'm saying is the rocket league linux port is awful.


Use ati. I get like 230 with just my 370.


Sadly, I can't. The amdgpu driver is the only driver that supports my card...


;-; that sucks


So... I resolved some mesa package errors but still: weird flickering, tearing is not resolved, freesync doesn't work & gaming performance is bad.

Borderlands 2 runs at ~50 FPS which would be nice if freesync would work :/

So maybe gaming on Linux isn't there for me yet (which is ok) how to get the flickering fixed? Any idea?


I think you're having the same issue maybe as Aremis in another thread. Did you check whether your monitor is being served frames at its native rate?


@Aremis how did you solve that?

@Zoltan Well my Monitor runs natively at 75Hz but "only" gets 59 Hz. I could set it to 75 Hz in the Settings there is that option but if i do that i have to reboot. Black Screen and no way of recovery.

edit: i disabled animations in the dconf-editor and it looks like that does the trick aswell, no idea if that is what Aremis did.


Eh heh, that was an issue like.... a year ago for me? I lilled all the fancy anomations and changed DE's, eventually went to wayland.


I love drugs as much as the next guy :)...AMD love them more :)


disabling animations doesn't work. when I resize windows and terminals and stuff I get weird glitches and graphic glitches.

$ lspci -k | grep -A 2 VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480] (rev c7)
	Subsystem: XFX Pine Group Inc. Radeon RX 480
	Kernel driver in use: amdgpu

is there an infographic on how drivers and mesa renderers and all that jazz works together? I have no idea how all that software works together but I really wanna make it work.


WAYLAND?! Are you GAMING on wayland?! If yes, then holy shit, how? For me, gaming on wayland has been an absolutely awful experience!


Mine does the exact same thing, but it does this all over the screen. I'm still looking into the clock rate to see if it's that but I'm so far I'm pretty sure it can all be configured in the /etc/X11/ directory, just need to find the right recipe.


do you have that bug where when you set the hz rate to 75 from 59.xx it just gives a blackscreen without recovery?


You mean manually on the monitor itself or inside a configuration file? Cause in my system settings I only have the option of "auto" or "60Hz" in the dropdown highlighted.


what distro are you using? this settings panel looks sophisticated in a good way.

edit: my x11\xorg.conf.d\ only contains 00-keyboard.conf

do i just create a new config file and start messin' around?


I'm using Opensuse Tumbleweed KDE, I find that strange to only have a keyboard config file in that directory, I also would not advise messing around with it if you don't know what your doing.

Here's a link for Xorg if your interested:


I was in netrunner all year long and it uses eayland so yeah o-o just with the ati driver. Sadly netrunner rolling is unusable now so thats out of the question.


Just installed 16.04 to try to get AMDGPU-PRO up and running for dat FreeSync :O

That was way easier than I thought it would be, to be honest. Too bad it's obnoxiously difficult to get AMDGPU-PRO on Manjaro...