Return to

The AMDGPU Info/News Thread



Poor intel, if only we could pay them 8 million for netbook grade CPU's. I feel bad.



Is anyone here using Blender 2.78a with kernel 4.8.13 (not Ubuntu, RHEL, SLES/SLED, and CentOS) and AMDGPU, without any graphics glitches, screen artefacts ?
Web browsers without (partially) black and distorted tooltips when hovering, and corrupted animation area when pressing F11 (full screen) and window resizing (with title bar buttons),

I'm on Arch Linux, currently with Deepin. But I also tried with KDE, Gnome, Budgie, XFCE (just to rule out DE issues) with the same bad result. These DEs were all fresh installs, on top of a fresh Arch installation, not all at the same time.

I have a RX 480 8GB and RX 480 4GB in one box. The 8GB card is meant for rendering with Blender.
In Windows 8.1 and Ubuntu 16.04 (w/ AMDGPU-PRO) these issues do not occur,

I'm terribly disappointed with this situation, because I spent €610.-- on the 2 cards and can't even use Blender.

There are still no generic AMDGPU-PRO Linux drivers. Just for Ubuntu, RHEL, SLES/SLED, and CentOS.
So I borrowed a GTX 1060 6GB to use Blender. And there were zero issues with Blender and web browsers for me with the NVidia card. The problem is that card would add another €295.--. Money I budgeted for a new PC build.

I'm left with 2 door stops "worth" €610.--.


for me, when i enter blender it goes black and white+radom artifacts when moving and stuff (arch+xfce) amdgpu+mesa+llvm+gallium


For full features use AMDGPU-PRO for the time being, RadeonSI and AMDGPU are still HEAVILY experimental drivers as far as I'm concerned, they have a list of issues longer than the great wall of china, just check up on GOL or PHORONIX with comments about recent Valve driver queries.


Same here. Just not black and white. When Blender is started, I can see small and large blocks of other applications and/or the desktop wallpaper in the Blender window. Blender menus at the top open, but corrupt right away with the same artefacts as soon as they are hovered with the mouse cursor.

I wish that I was able to use AMDGPU-PRO. But as I said I'm on Arch Linux, and there is no official AMDGPU-PRO as of yet. The AMDGPU-PRO drivers in the AUR do not compile for me. I encounter the same as issue #25 here : . Even though it's out-of-date (many updates have come and gone) and semi-abandoned I would still install it, if it would display the Blender UI correctly. It will just not compile.


What happened to the rumour that Overclocking can be done only inside OS? I hope this will not be implemented.


Never even heard that rumour before. Where did you read this?


5th bullet point



hey there! i am currently doing something completly unrealted but i found this in the dmesg output

1.096932] amdgpu 0000:01:00.0: Invalid ROM contents

is this something i should worry about and/opr try to fix this?


I'm not even sure what ROM its referring to.... GPU BIOS? I wouldn't be worried unless it does something.


hi, have this too on ubuntu with amdgpu pro drivers and radeon R9 390

[ 1.982057] amdgpu 0000:01:00.0: Invalid ROM contents

but shouldn't be anything to worry about:

You can ignore the "Invalid ROM contents" message. It was due to a change in the rom handling code in the pci subsystem. It's harmless.



ok, good.

does anybody have a rx480 with the performance BIOS from XFX?


I get it too. Well not Invalid ROM contents

[ 0.498843] pci 0000:01:00.0: Video device with shadowed ROM at [mem 0x000c0000-0x000dffff]
[ 13.131275] amdgpu 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff

ASUS strix RX480


is there any BIOS from ASUS for the rx480?

maybe we could try some BIOSes and see what happens

A segment in LevelOneTechs I'd love to see

Reporting a fresh install of Ubuntu Gnome 16.10 works with amdgpu-pro 16.5 with an rx480.

One line in the amdgpu-pro-install script needed to be edited because the referenced sources directory was missing a slash. GG amd.

Not too painful.


I did that and the edit in the install script but less games worked than straight up native amdgpu so I went back.


As a separate thing, I'm trying to start the amdgpu-pro installer and it doesn't seem to want to start at all. I got the package from the aur. Is there a better package somewhere?


crossfire is now supported for Vulkan on Linux.


Has anyone got "tearfree" / vsync to work on a multiple monitor setup with amdgpu? I have a 390X and followed this guide: (I didn't follow the 'nomodset', no loop or anything happened so it's fine).

I'm new to the configuration of amdgpu and xorg handling the display servers so please, do think that I'm retarded :P