The AMDGPU Info/News Thread

hey there! i am currently doing something completly unrealted but i found this in the dmesg output

1.096932] amdgpu 0000:01:00.0: Invalid ROM contents

is this something i should worry about and/opr try to fix this?

I'm not even sure what ROM its referring to.... GPU BIOS? I wouldn't be worried unless it does something.

hi, have this too on ubuntu with amdgpu pro drivers and radeon R9 390

[ 1.982057] amdgpu 0000:01:00.0: Invalid ROM contents

but shouldn't be anything to worry about:

You can ignore the "Invalid ROM contents" message. It was due to a change in the rom handling code in the pci subsystem. It's harmless.

src: https://www.phoronix.com/forums/forum/linux-graphics-x-org-drivers/open-source-amd-linux/45819-radeon-0000-01-00-0-invalid-rom-contents

2 Likes

ok, good.

does anybody have a rx480 with the performance BIOS from XFX?

I get it too. Well not Invalid ROM contents

[ 0.498843] pci 0000:01:00.0: Video device with shadowed ROM at [mem 0x000c0000-0x000dffff]
[ 13.131275] amdgpu 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff

ASUS strix RX480

is there any BIOS from ASUS for the rx480?

maybe we could try some BIOSes and see what happens

Reporting a fresh install of Ubuntu Gnome 16.10 works with amdgpu-pro 16.5 with an rx480.

One line in the amdgpu-pro-install script needed to be edited because the referenced sources directory was missing a slash. GG amd.

Not too painful.

I did that and the edit in the install script but less games worked than straight up native amdgpu so I went back.

As a separate thing, I'm trying to start the amdgpu-pro installer and it doesn't seem to want to start at all. I got the package from the aur. Is there a better package somewhere?

http://www.phoronix.com/scan.php?page=news_item&px=RADV-Multiple-Devices-Patch

crossfire is now supported for Vulkan on Linux.

1 Like

Has anyone got "tearfree" / vsync to work on a multiple monitor setup with amdgpu? I have a 390X and followed this guide: https://forums.opensuse.org/showthread.php/522107-How-to-install-amdgpu-driver-for-AMD-Radeon-RX400-Series (I didn't follow the 'nomodset', no loop or anything happened so it's fine).

I'm new to the configuration of amdgpu and xorg handling the display servers so please, do think that I'm retarded :P

It's just in settings, you activate vsync and it's activated. The default is "only when cheap" or "auto" I think, depending on what DE you're using.

If you're unsure whether or not your setup CAN do vsync, just check glxinfo.

EDIT: Well, this is awkward, got up this morning, booted up tumbleweed, there we have it, no screen tearing. lol

EDIT 2: Nevermind, it's still there, not sure if it's actually screen tearing but when I move objects or hover over elements fast enough or play a video on one screen, it makes very subtle and partial screen tears.

Thanks zoltan for the reply, I'm on tumbleweed opensuse

I have this set in my compositor:

And here's my configs:

/etc/X11/xorg.conf.d/50-monitor.conf

Section "Monitor"
        Identifier "Default Monitor"
EndSection
#
Section "Monitor"
        Identifier "Secondary Monitor"
EndSection

/etc/X11/xorg.conf.d/50-screen.conf

Section "Device"
        Identifier "AMD Radeon R9 390X"
        Driver "amdgpu"
        Option "DRI" "3"
        Option "TearFree" "true"
EndSection
#
Section "Screen"
        Identifier "Default Screen"
        Device "AMD Radeon R9 390X"
        Monitor "DisplayPort-0"
EndSection
#
Section "Screen"
        Identifier "Secondary Screen"
        Device "AMD Radeon R9 390X"
        Monitor "DVI-D-0"
EndSection

/etc/modprobe.d/50-blacklist.conf

#
# $Id$
#
# Listing a module here prevents modprobe from loading it via modalias (only
# aliases from /lib/modules/*/modules.alias). You may still load it explicitely.
# We blacklist some modules becaus they may harm on certain devices or they
# prevent other modules from grabbing the device.
#
# Syntax:  blacklist <driver name>
# See 'man modprobe'.
#

# Manual/User input
blacklist radeon
blacklist fglrx

# usbcore ... module is loaded implicitly, ignore it otherwise
blacklist usbcore

# tulip ... de4x5, xircom_tulip_cb, dmfe (...) handle same devices
blacklist de4x5
# At least 2.4.3 and later xircom_tulip doesn't have that conflict
# xircom_tulip_cb
blacklist dmfe

# list all framebuffer drivers, some of them tend to crash during boot
# they are either compiled into the kernel, or vesafb is active
# X works fine without them, rcfbset can load them if really required
#  sed -e '/\/drivers\/video\/.*\.\(o\|ko\)$/{[email protected]^.*/@@;[email protected]\..*[email protected]@;p};d'
blacklist aty128fb
blacklist atyfb
blacklist cyber2000fb
blacklist g450_pll
blacklist hgafb
blacklist i2c-matroxfb
blacklist i810fb
blacklist intelfbdrv
blacklist intelfbhw
blacklist matroxfb_accel
blacklist matroxfb_base
blacklist matroxfb_crtc2
blacklist matroxfb_DAC1064
blacklist matroxfb_g450

etc....

GPU info:

/sbin/lspci -nnk | grep -A3 VGA

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii XT / Grenada XT [Radeon R9 290X/390X] [1002:67b0] (rev 80)
        Subsystem: ASUSTeK Computer Inc. Radeon R9 390X [1043:04df]
        Kernel driver in use: amdgpu
        Kernel modules: radeon, amdgpu

What's funny is that it's still using radeon even when I blacklisted them...

I wasn't sure how to link the monitors to the screens, so I looked up the xorg wiki and tried to figure out how it worked, this was my understanding, please feel free to point out my mishaps.

New -PRO is out:

https://www.phoronix.com/scan.php?page=news_item&px=AMDGPU-PRO-16.60

https://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Driver-for-Linux-Release-Notes.aspx

Looks it has some more extended hardware support...GCN 1.0 included...

And it seems to have issues with gtk DE (cinnamon at least...Anyone tried on gnome?) and with the dual monitors in mate...

Good start for the 16.60...

Fedora 25 with the 4.9.5 kernel is running wayland / AMDGPU fine for me with an RX 480. No screen tearing is nice. Not sure I can go back now.

Gaming wise it works some games the performance is slow others great. Im not gamming as much now so I can deal with that.

And according to phoronix the only the thing they improved is distro support. Thats like the second or third release with no actual improvements. Cant they just make a "normal" linux package, that can be repackaged to fit other distros. There arent too many people gaming on centos 7.3 and with every distro you can find someone who will maintain the driver package. WTF AMD. They should work on other things likes getting the kernel to work with new kernels (something that should have been fixed after they dropped fglrx) or improving performance (unless of course they did those two things without telling us)

2 Likes

Which distro are you using? Tomorrow I might just spin up an ubuntu install to test out the driver. Im just wondering if its finally compatible woth 16.10 (but it definitely wont work with 17.04 once thats out)

It does not look compatible with 16.10 from the release notes and the install scripts. I tried it on Mint with the 4.4 kernel active. I might try to also try an ubuntu gnome install just to see if the issue is with all gtk DEs if i have the time.

Maybe they are targeting miners or OpenCL programmers that can be using CentOS and require the PRO.

It seems that with this one the hardware support is complete which is what the focused on until now. Maybe now they can finally make the driver more streamlined.

Damn, I didn't even think of opencl but it kind of makes sense, it is the pro driver, after all. No ubuntu 16.10 support still sucks though. Companies need to stop assuming everyone's on god damn LTS. Hopefully theyll at least make the driver compatible with the next lts kernel (i think that might actually be the upcoming 4.10) because running the outdated 16.30 on arch linux is no fun