System won't turn on after unplugging PSU

Hi everyone,

I think I have a bricked MSI X570-A Pro but I thought I’d give it a try before getting a new one.

The hardware used is aforemoentioned mainboard, a Ryzen 2200G aswell as a 3800XT and Patriot Viper 2x4GB DDR4-3200 memory sticks. PSUs tested were a Corsair 650W and a BeQiet 850W.
All interchanged hardware is known good since pulled from working systems for testing.

The symptoms with the board are as follws:

With CPU and RAM installed powering up the PSU and hittig the Power-Button literally nothing happens.

Flashing the latest BIOS using the BIOS-function of the board with no hardware at all attached to it didn’t solve the issue (Only things plugged onto the maoboard were PSU and USB-stick).

When installing ONLY the RAM the board would power up.

When installing ONLY the CPU nothing happens.

When installing CPU and RAM nothing happens.

When having the PSU turned on and then umounting and remounting the CPU the system would then turn on and POST.

After that the system can be used as if there was nothing wrong with it.
It can be turned on whenever it’s shut down and Power-Button is pressed.

Well, until the PSU is unplugged or ‘just’ turned off via the switch on the PSU. When doing that you need to have to unmount and remount the CPU again.

Since I can imagine that this procedure is not very healthy for the CPU besides the fact that it’s quite annoying having to do that every time the psu needs to be unplugged I wonder if there is anything on my end that can be done other than retiring it.

Any ideas anybody? :slight_smile:

Thanks in advance everybody

My first step would be to check the cpu & socket for damage.

Thanks for the tips.

But like mentioned the CPUs were pulled from working systems and the pins are undamaged.
I’ll try to inspect the socket closer this evening if I can see anything strange through the holes.
The covering sled is in perfect condition though.

EDIT: Sorry, overread that you already tried this, my response is in vain :frowning:

But would maybe retry it, this feature can be buggy sometimes, this is why I remove the CMOS battery etc. beforehand.

I’ve experienced the very same error pattern with a corrupted X570 BIOS. Had to use the “USB flashback” feature to restore functionality.

Guide:

  1. Disconnect PSU from AC power;

  2. Remove the CMOS battery for 10 min;

  3. Reseat CMOS battery;

  4. Reconnect AC power;

  5. Follow MSI’s instructions for the use of an USB thumb drive to reflash the complete NVM of the motherboard;

  6. Hopefully success?

It sounds like you’ve got it pretty well narrowed down to being a bad motherboard. But just confirming that you’ve disconnected absolutely everything from the board aside from CPU, RAM, and PSU? No M.2 drives, RGB, USB Headers, Power/HDD LEDs, reset button, case audio, connected sata cables, etc.? And last step before calling it dead would be to pull the mobo from the case just eliminate the possibility the PCB is somehow shorting to the chassis.

Out of curiosity what happens if you:

  1. Turn PSU power switch off
  2. Push PC power button a few times
  3. Disconnect ATX and 12V cables from motherboard
  4. Clear CMOS
  5. Turn PSU power switch on
  6. Connect ATX and 12V cables
  7. Push PC power button

Edit: And just 1 stick of RAM in slot A2?

Your motherboard has an 8-pin CPU_PWR1 socket. Is that connected to your PSU? (The required cable is probably labelled ‘EPS12V’.)

Many modern motherboards don’t boot if all you have connected is the 24-pin ATX_PWR.

The 4-pin CPU_PWR2 socket is only needed for ‘extreme’ overclocking, so can be safely ignored for now.

Thanks for your help so far but I think I need to clarify the setup a little further…

Currently the setup is as follows:

  • The mainboard is mounted to an open test bench
  • The PSU is connected to the board via ATX- and 8-pin-EPS-plugs
  • A single stick of RAM is mounted in A2 like stated in the manual
  • Only the power-button is connected

When NO CPU is installed the board would power up every time I press the power-button and can be turned off again. It doesn’t matter if memeory is installed or not.

When the CPU is installed nothing happens when pressing the power-button. It doesn’t matter if memeory is installed or not.

When the PSU is switched on and the CPUthen is taken out and reseated again the system will power on by itself and work just fine. In this state the system can be booted and shut down every time without a problem. As long as the PSU isn’t turned off.

It even would turn on after usig the BIOS-flash-function.

But I think you agree that both ways aren’t really feasable.

I wouldn’t mind to toss the board if it’s really dead but if there’s a way to solve its issue than I’ll sure give it a try.

The only other thing I can suggest is using a multimeter to check the voltage of the motherboard battery.

A fresh CR2032 will register around 3.0V. I’ve seen weird behaviour when that drops below 2.3V. When the PSU is turned off, certain circuits (e.g. clock, chassis intrusion) are powered by that battery. If the battery voltage has dropped too low to reliably power those circuits, the boot process can become unpredictable. I’ve personally experienced the boot process being aborted/halted as a result of a weak battery.

Either check the voltage with a multimeter, or swap the battery with one from another (newer) motherboard (that isn’t experiencing issues). It’s a quick and easy test to rule out the battery as a possible cause of your woes.

1 Like

test all the other components in your other build…
if they all work including the drives and psu.
then bin the motherboard.

the fact your pulling stuff out and plugging it back in and it turns on.
points to your board having a broken resistor that’s stopping the system starting.
plugging the cpu in is likely causing a re-route of power from elsewhere on the board, enabling the system to boot.

so yeah test all the components in another build. if they work, bin the motherboard.(or sell it spares and repair on ebay)

Hi guys,

ehm, did you ever have a piece of hardware troll you so hard that you feel the urge to take that hardware and throw into the sun?

Yesterday before heading off to work I decided to give it a shot trying to boot the system regularly, say turning on PSU and pressing the start button.
As expected and as all the times before nothing happened.
I pressed the power-button a few times just in case but the system remained dead.

I let the system remain in this condition and headed to work.
Clearly not the smartest move in terms of safety but since I had it located in the middle of the garage with nothing else there to catch fire I thought I’d give it a shot.

Now here comes the spooky part.
When returning from work yesterday evening I had a look and found the system powered up and in BIOS.

And guess what…

I powered up the system and turned it off about 20 times with a ‘hot’ PSU, meaning I didn’t flip the switch on the PSU.

After that I powered up the system 20 times with a ‘cold’ PSU, meaning I always flipped the switch on the PSU.

I don’t know WHAT happened and clearly I don’t kow HOW it happened but somehow the gremlin left the mainboard.

Certainly I’ll never use this board for any kind of critical usecases but I’ll keep on testing it in the near future to see if it just was it’s swan song or if it’s back for good.

Thank you for your help guys, it’s very much appreciated.

I’ll keep you in touch from time to time how the fairs…

2 Likes

If this had happened to me I would have tried a different PSU and see if the problem persisted. You could have had some nasty software or firmware happening that needed to resolve itself. PSUs these days are geared for power saving options and there’s a chance you may have been using one of those. I realize this is a late response but it still wouldn’t hurt to test this with a different PSU.

Put a rocker switch to the GREEN wire and Black wire form the power supply. It is the last ditch effort. Tho, I had a virus in my 570 pro BIOS. It almost did the same thing! I downloaded the lastest BIOS and installed it. It was taking 20 seconds to 5 seconds!