Sysadmin Mega Thread

All true, but I wouldn’t consider running those on top of macOS a “hypervisor” strictly.

Managed to crash the Centos 8 installer trying to edit the network config.

Full disclosure, I am mounting the iso via ipmi through a vpn tunnel, so who really knows what happened.



Ahhh, nothing like Day 0 issues.

1 Like

I haven’t noticed this, however I’ve not worked on massive datacenter size VMWare setups. But have seen it handle up to 100+ server environments no problem.

I do feel like any of the one’s I’ve tried, such as proxmox would need to be segmented before they got too convoluted though. And just for the sake of security you probably should not have that much stuff managed by 1 single management system.

1 Like

Do you only see the benifits of the “-z” flag on rsync if you run it on the machine where you’re moving the file from?

Assume file is on System A and I am going to rsync -az to System B, does the compression and associated network bandwidth savings take place only if I run the rsync command on System A?

It should work no matter the machine. what you have to consider is the file type. Media files don’t compress well.


Is it typical of mounted NFS shares to drop connection during a cp of >30GB?

Assume NFS share is /DATA/ on local machine. When doing cp -r /DATA/ /newFolder/

You cannot ls /, df -h won’t complete, you cannot cd /DATA/.

When this happens the mount point can’t be “ls” and /var/log/messages is saying nfs: server {servername} not responding, still trying (on the client machine).

No, that’s not typical.

Check the switch and syslog on the server for errors?


Thanks for the reply.

/var/log/message states
nfs: server {servername} not responding, still trying

dmesg is same as above.

Nothing is in the event viewer of the NFS server.

The mount enters this weird state during these cp runs. Basically, it’s unreachable via the command line. Makes it so that directory can’t be stat’d, but it appears to be moving data, because the directory /newFolder/ (from my example above) is populating with data.

I regularly push 100s of GB to an NFS share through a VPN tunnel.

Check for packet loss?

1 Like

Damn it, I think I lost my IODD.

Coworkers steal it after finding out its greatness?



Can’t happen!

1 Like

I don’t have any coworkers who could even fathom what it does. I think I just left it somewhere or it fell out of my bag. I need it this week, so I ordered another one. I don’t hate the idea of having two in case I find the other one.

1 Like

Honest to god thing that was said out loud by the president of a prominent defense contracting firm and one of the most talented software engineers I have ever met, “Damn it, (insert name of gov managed web portal) uses a self signed certificate and Chrome keeps bitching about it and will not let me continue. You know what wouldn’t complain? Internet Explorer!”. He says this while typing away on his specced out Imac Pro.



No, NFS should not drop.

I run my entire VM infrastructure off of NFS mounted shares, and our local backups are 22TB plus… over NFS… without drops… never mind the daily traffic the servers hosting all that do in live production environment without drops…

NFS should not drop, period - unless the host goes off-line or the network breaks.


event viewer

Uhh, is it a windows server?

If so, I’m even more out of my element than I initially thought. (never seen that issue before when it wasn’t caused by packet loss)

1 Like

Sounds like it’s time for you to implement letsencrypt and get a raise…

Kinda sysadmin related - but if anyone here uses an ipad and was wishing for mouse support… it works pretty well in iPadOS 13.1 :slight_smile:

Good enough for RDP sessions, and a heap of mouse shortcut stuff actually works in native iOS applications. I’m going to test it out with a magic trackpad when i get home today, but if that works pretty well as well (and i can’t see why not) then a magic trackpad plus ipad is a very, very lightweight remote administration machine. That isn’t super fucking annoying to use windows on via RDP any more.

Also… finally. New-tab in ipadOS safari automatically selects the address bar to type into! Woohoo!

1 Like

I can’t wait for the day that when you plug an iPad or iPhone into a monitor/projector the device displays a proper desktop window manager.

I dream highly of the day that all one would ever need (outside of gaming and other high end performance and sysops things) is a phone/tablet