Return to

Sysadmin Mega Thread

We ran some updates recently and a Python 3 version completely screwed up our Chef builds.

When we were trying to upgrade from 7 to 8, all of the instances we tried either broke, failed to upgrade entirely, or would continue looking for 7 repos instead of 8.

I’ve not experienced that with Ubuntu or Debian.

Granted, I’ve inherited this environment, so it could be something in the configuration management/configuration drift. I’ve never had a problem with RHEL/CentOS until I worked here.

Ah, could be a compatibility issue with Chef, I suppose. I don’t use it.

I believe this is officially unsupported. AFAIK, you have to rebuild the server to move to a major release. This sucks in a way, but at the same time, any important server should be push-button redeployable.

Lol dude. Not here. I’m working on it. In fact, I was hired specifically for this. But they’re deeply rooted in old habits. Nothing wrong with that, it’s just going to take more time than the day after I was hired.

Yeah, we were looking at upgrade paths to just test RHEL 8. It is what it is. Works fine :wink:


Wow, @wendell, you casually dropped this in the unraid vs freenas video. I can’t believe I didn’t know about it. So awesome.


Yeah, FOG is great for deployment. I found it doesn’t work well with my use-case though.

Yeah, I saw macOS support and was psyched, but digging deeper, it looks like that is heavily caveated… Still good for servers and whatnot.

1 Like

As with everything osx

Caveat: use jamf

there is also

so I’m guessing

1 Like

I don’t admin WIndows machines*, but that does look nice.

Just to complete the circle, here is a macOS solution. It is Jamf, but is FOSS according to the license.

* Technically I do support 3 Windows machines.

it runs fine on not windows.

1 Like

Serva is a light (~3 MB), yet powerful Microsoft Windows application

I see you can serve non-Windows clients, but it looks like it has to run on Windows?

one of the guys at work claims it works in wine, but I haven’t ventured down that path myself


for that is the path of darkness and depravity

1 Like

Responding to AdminDev reminded me I needed to make a snippet about how to deploy to Heroku from GitLab.


Fucked my shoulder replacing a 2200w APC yesterday. PT scheduled for tomorrow :frowning:

Oh damn, lift with your back, not your shoulders.


Started next semester of my BA program earlier and decided to stop being lazy and load some linux VMs to play with, one of which is Fedora. Looks pretty great, and noticed an interesting program for remote computer management, Boxes. Does anyone here/have actually use Boxes, and is it any good?

Oh, and I upgraded my FreeNAS to U7 and did a scrub. 0 errors. Not sure what it is with that update that’s causing some issues for people

Couldn’t do that until it was out of the rack unfortunately. It’s an old injury I’ve never had properly address so I’m actually glad I have an opportunity to go to PT for it.

For me, it’s definitely specific to that one system. I have others on u7, no problem.


I just use xfreerdp for management honestly. It’s easier imo. Just make a quick bash .desktop file that’s executable from the desktop and functions the same as windows rdp. Boxes has a decent minimalist UI for VNC, but I just use Real VNC