Stuttering and freezes on new ryzen system

I build a new ryzen system 1800x with an MSI X370 Titanium MB and 16 gigs of Corsair Dominator RAM plus a 250 Gig Samsung 960 EVO nvme drive. I dual booted fedora 25 and win 10 and I'm experiencing some weird behavior on the windows side of things. Whenever I boot into windows I get stutters and sound cracking and the disk sometimes sits at 100% usage for no apparent reason. Games are freezing up and crashing. I did a new install on both the linux and the windows side and there are no errors or anything to go on. Anyone got an idea?

Are you using the maximal performance power plan?

Yes, i had more audio cracking on the "balanced". But it's still not gone.

I recently saw a video where the reviewer had some very weird behavior from that mainboard's BIOS. Try reset to defaults or use CMOS Jumper.

I will certainly try that, do you happen to have a link to that video?

I'm trying to remember who and where I saw it, but just go ahead and try that nevertheless.
If it clears up the issues then you'll be all set.

What's the bios revision your on? Try updating to the newest revision.

Sadly it didnt work, game crashes and system feels unusably slow. I had to restart to type this message, mousecursor keeps getting "stuck", keyboard ads a lot of letters at once or doesnt even respond. And task manager shows no weird usage.

I'm on the latest bios revision 1.5

Is your windows install fully updated? There was some talk of ryzen specific optimizations and bug fixes being quietly done on win 10

I thinks so, Windows Update says it is up to date

Reminder to not only have an updated bios but fully updated windows and drivers. disabling xbox dvr stuff is also recommended. A Hardware monitor would be in order, also.

What kind of hardware monitor?

Drivers are from MSI themselves, also the newest versions

Open hardware monitor, CPUID hardware monitor, either really. Just to check in on temps and such.

Sometimes rolling back drivers helps. Look in the the device manager and see if you have any driver issues. You might even uninstall MSI temp and roll stock amd utility just to test.

The device manager says there are no issues. I also tried the generic drivers from Microsoft to start with. The weird thing is that under linux it appears to work fine. But haven't tried to game on linux yet. I did have some issues but I think it's the graphic driver on the linux side of things.

What about disabling xbox game dvr function ? Dual boot as in two different drives ?

I disabled the DVR, but to no avail. I dual boot on 1 nvme disk.

I personally avoid booting windows and linux off the same drive even tho it is possible. How about driver for nvme .