Struggles with new R9 390 and any GUI environment

Hi all,

Today I received my PowerColor R9 390 which I’ve been looking forward to getting for ages to replace my GTX 970 because i wanted to use open source drivers. However, when i booted into Arch, I saw a cursor for a tiny amount of time and then just a black screen with a blinking cursor. I can switch between ttys perfectly fine, I just can’t get into Xorg. On this Arch install, I tried gdm and lightdm to no avail, and even tried copying the default xinitrc to see if i could get anything and it said that line 2 was successful but then i just get a blinking cursor again, and when i Ctrl+C out it says connection refused.

I then tried an Ubuntu 20.04 live USB which I could get booting onto a GNOME live environment if I set either nomodeset or radeon.dpm=0 as kernel parameters (the latter of which I couldn’t get to do anything on Arch). This behaviour is indentical with Fedora Workstation 32 as well, although without any kernel parameters i saw the GNOME live session flash for a fraction of a second before going black which i hadnt seen before (usually it’s a cursor then a black screen).

Am I basically fucked if I want to run Linux without kernel parameters with this card? I’ve even tried forcing amdgpu on my Arch install with kernel parameters (as lspci -k shows that i’m using radeon by default) and that didn’t work (yes I had the corresponding xf86 packages for both drivers).

Full specs of the machine are
Xeon E3 1231 V3
MSI Z97 PC Mate
PowerColor R9 390 (the culprit)
EVGA G2 Supernova 750W

Ok, so I’ve pretty much figured out the problem - the kernel with this card defaults to radeon drivers which is the issue. As a result, I need to use the AMDGPU drivers and use these parameters
radeon.cik_support=0 radeon.si_support=0 amdgpu.cik_support=1 amdgpu.si_support=1 amdgpu.dc=1

Smells like this:
So yeah, 390 seems broken by default.

it seems like the dpm stuff was fixed. try with just:
radeon.cik_support=0 amdgpu.cik_support=1 if you use amdgpu or
radeon.cik_support=1 amdgpu.cik_support=0 if you use radeon

1 Like

Thanks, I’ll give it a go just with those parameters rather than using all the ones I posted and see how it goes - let’s hope it goes well as typing those in is tiring lmao.

Why a 390? Polaris is so cheap these days.