Strict B550-f gaming motherboard not posting ghaaa!

Ok so I was attempting to oc my system ram to 3200 MHz (cause it’s supposedly rated for that.) but it was running at 2333 instead. Got into bios, unlocked the proper frequency, aaand now my board game sent posting. And yes, I reset my cmos. I’m pulling my hair out. :triumph: what am I missing???

Sometimes to do a proper CLEAR CMOS you have to unplug the power to the computer, let it sit for a couple of minutes and pull out the CMOS batter and see if the mobo has a CLEAR CMOS jumper and short it or use a jumper block, if available.

Leave it cleared for a minute or two and then reverse this process and try once more.

See if this doesn’t properly reset the RAM speed back to to the default JDEC spec of 2333.


I’ve done that. All of that.

I’m not sure what would cause that to NOT reset then.

Have you got any other RAM modules to try out ?

Also did you try just a single stick in each of the slots ?

Maybe you have a faulty memory channel on the CPU ?

1 Like

I have a mismatched set that I know works. Tried it, no signal out, no beep codes, not leds nothing. I tried a single stick, but I haven’t tried every socket. Omg What a relief! It posts with one stick in the a1 slot???! weird as heck. How would I know if my main board has a faulty memory channel? Hmmm I think maybe one of my dimms is not faulty but marginal???

You can only test IF you have another CPU to confirm it isn’t on the CPU itself.

Generally you do not see mobo’s having a channel issue, since the CPU has the integrated memory controller on it.

just a heads up.
this isnt how you clear the cmos…

to clear the cmos via the battery terminals.
you turn off system power. pull the battery.
then turn on the system power (psu switch at the back).
the motherboards led’s will light up or flash.
now turn off system power and quickly short the +/- terminals of the battery socket.
the aim is to use residual current on the board to clean the cmos eprom.

just removing the battery without shorting the terminals after wont do anything.
even if you leave it out 24 hours.
sure the bios settings will clear. but the cmos wont as the cmos eprom needs high voltage to clear it (about 20w). not zero voltage.

1 Like

op clear the bios and cmos.

unplug and reseat the ram.
check your cables to make sure nothing has come loose.

restart the system and let the memory train.
this can take a minute depending on the amount of ram in the system.
so if all you see is a black screen. give it a minute and you should see the splash.

if that’s not working and your board has a dual bios (apparently it does)…
then again leave the system on…
after 30-60 seconds it should reboot and load in the alt bios and assuming that isnt corrupted also.