Return to Level1Techs.com

Strange problem, Socket AM3 BIOS ASUS fails to recognize many large disks

bios

#1

Hi all,
I write to you about a problem I faced for several years. I researched Internet. No one noticed this or I fail to locate their comments.
I’m not here asking for a solution. I just want you to share knowledge. I wish to understand what is going on.

Introduction:
I have a computer with Socket AM3+ with RAM ECC UDIMM.
Motherboard: ASUS M5A78L-M_PLUS_USB3_UM.
Running a Fedora Workstation 24 (64bits) (Linux kernel v4.12).
Using large hard disks for backups and a tiny development environment.
The computer has 6 SATA connectors (4 with AHCI, 2 in IDE Mode).
I was able to fully use all connectors: 1x BluRay, 2x SSD, 3x HDD (3TB). So the wiring and motherboard seemed to properly link and control the devices.

The problem (first round):
My problem was detected when I tried to connect: 4x HDD or more. Initially I wished to connect up to 6x HDD with 3TB each. I tested all disk combinations (wiring) and reduced the amount of disks. Till I understood: the motherboard is unable to boot with 4x HDD connected (3TB each, all of them brand Toshiba, same product model). As a workaround I can plugin disks via USB with an external cage. So I abandoned this problem.

The problem (second round):
Now I have a new HDD Seagate Barracuda 4TB (for backups). I tried to replace one of the 3x HDD(3TB) connected, with the new one 4TB. The motherboard now shows to have the same exact problem again. Even seen in BIOS, disk not shown (but recognized within BIOS menu options), or showing during boot a warning message with text: disk error.

I remembered previous problems and I simply disconnected all other HDD 3TB. Then it boots perfectly, with the same SATA controller, same wiring, linux boots fine, recognize the disk, can format and put data within. But when I try to boot again with 3-4 disks connected it fails in BIOS.

The problem (summary):

  • In the past I was unable to use 4x HDD 3TB: so I lived with 3x HDD 3TB.
  • Now I am unable to use 3x HDD (3TB+3TB+4TB): so I live with 2x HDD (3TB+4TB).
  • Note: I can use those extra SATA connectors with +1*BluRay and +2x SSD. Fine with those devices, not with large disks.

My final thoughts:
I do not understand what is going on. I come to this Forum because I wish to know. Before you get angry with me. I’m planning to move very soon towards Socket AM4 (Ryzen). To push the envelope to have 12-14x SATA HDD. But I am a little bit scared. What if I encounter this problem again. With a newer motherboard. What a waste of investment. Willing to bring back old storage disks into a live system. And not being able to boot due to BIOS problems.

I understand that AM3 AHCI SATA Controller has some limitations. But I do not know them. And I am confused to see:

  • 3*HDD is OK with: 3TB+3TB+3TB.
  • 3*HDD is not OK with: 3TB+3TB+4TB.
    Same placement and wiring. I do not see a big difference in configuration.

I hope anyone can share a comment. So to guess what could be happening. Therefore prevent this kind of error from happening with newer systems.

Thanks in advance for your support.