Steam (was X470 Taichi BIOS 2.0) stability under Linux Kernel 4.20

Hey guys,

I just upgraded my taichi bios to 2.0.0 and now, i can boot into the desktop, but as soon as i load Steam it locks up. repeatable issue.

Memory timings are set to same or slower as they were with Bios 1.6, system was stable previously. Have also set memory speed back to ddr4-2133 and same result. Memory is DDR4-3000 previously running just fine at 2800 (2x dual rank 16GB DIMMs).

It seems stable in Windows.

Has anyone else seen this issue? Kernel 4.20.0 (i think) with Ubuntu updated via ukuu.

I don’t particularly want to downgrade BIOS if i can avoid it, as 1.6 (previous stable) has some bugs that impact KVM and (IIRC) VFIO, and 1.5 is pretty ancient (which is what it shipped with when i bought it).

Getting awfully tempted to piss it off and replace with an ASUS board to be honest, due to the shitty BIOS update frequency.

I would be tempted to down grade the BIOS version to see if the problem goes away.

I’m 99.99% sure the issue likely will go away. But more so wondering if anyone else knows if this issue is perhaps fixed in some version of the kernel and/or other library version(s).

I want BIOS 2.00 to fix some other bug(s) and get the new AGESA, so not wanting to downgrade unless i really must.

Another thought, maybe try re-installing steam? I suggested the bios change partly to determine if it was the bios change that caused the problem.

This was the motherboard I was planning to buy so it would be good to know if it is the bios.

Looks like i was lead astray…

BIOS likely not at fault, i rolled back and still broken.

May be a kernel issue… rolling back the kernel to 4.19

yup. kernel 4.20 with my hardware (vega 64 and x470) - steam locks up the UI hard. kernel 4.19 is ok. wierd.

Confirming: BIOS 2.00 is NOT the issue. Ubuntu kernel 4.20 is.

1 Like

Update: just realized i didn’t list the symptom that prompted this post and diagnostics:

Opening Steam (for Linux) would result in hard GUI lockup just prior to opening the main steam window. SSH still worked, but steam would lock up the UI 100% of the time with kernel 4.20. Machine totally fine in windows, and totally fine not running steam in Linux.


Rolled back to 4.19 and the problem went away, BIOS 2.00 is fine.

I know I have 4.20 running at home on the Taichi ultimate and I also do use steam. I did not encounter that issue. I’ll test it when I get back. I am on kubuntu though.

I’m on Ubuntu 1804, running kubuntu desktop (i.e., installed from ubuntu distro, added packages) on Vega 64.

Could be driver/kernel interface related perhaps, but definitely, 100% rolling back to kernel 4.19 fixed it. Problem was entirely 100% able to be replicated across bios 1.60 and 2.00 running kernel 4.20.

Update: moved to the relevant forum, as i don’t think this is necessarily X470 Taichi BIOS related…

Ubuntu updated via ukuu

Seen similar problems with Arch v4.20 kernel reported for Ryzen systems
solution was to stay on V4.19

Yeah sure. Not expecting official support.

Production use = work

Later kernels have better Vega support.

But yes thanks for confirming 4.20 is having issues elsewhere.

Still, an application locking up the UI so that the only way to fix is via ssh is a pretty major regression.

What did Linus say continually a few years ago on LKML regarding systemd? “We don’t break user space!”

It is still a release kernel.

I am basically on the same kind of hardware including Vega64 for the GPU and I did not have any issues. I did play Doom 2016 for a while and it was just fine. Two things that might differ: I am on the beta stream of the steam client and I have disabled all energy efficiency stuff including C-States in the BIOS of my Taichi Ultimate.

Still not home for testing but I will be later today.

Life happened… Will look at it later.

1 Like

OK, I had 4.20 rc5 running before and I just updated to 4.20.5. Both of them did not have any issue with steam. I also just checked the UEFI and I am on version 1.36A, which is a beta version and pretty old at this point.

1 Like

Maybe its fixed in the beta steam client. I’m on the non beta client i think, will check to confirm.

I’ll try upgrading kernel again when 4.21 comes out, by that time either the issue i’m tripping up between the kernel and steam will be fixed in the steam client by then, or the kernel will be different and not run into the issue.

I also have not touched c-states. For me, the only UEFI changes i have made are memory timings, boot device and turning on SR-IOV and virtualisation support (yup, aware there is likely performance to be had, but i don’t care about chasing the last couple of percent, i’d rather just use the system and not have to spend so long reconfiguring after UEFI upgrade).

But thanks for confirming you’re OK.