Return to Level1Techs.com

Star Citizen News

star_citizen

#62

Hm… Enter-esting… Makes it more enticing, for sure.


#63

Worth a play around while its free. i think its free until the 30th.


#64

Played around in it a bit. Is there any trick to getting delivery missions to actually work? I keep running into bugged missions.


#65

Right now i have a mission in deep space, but no idea how to actually find it on the map so i can get there :smile:


#66

Yeah those can be a pain. They need to do a lot better on the navigation and map stuff.


#67

i think i might still prefer elite dangerous (though i need to play it more :smile:)


#68

That game has been in my Steam wishlist for 2 years, now.

No idea when I’m going to pull the trigger. I had an opportunity to get it for maybe $4 and froze when it came time to buy.

I have too many games in Steam that I’ve never installed lol. Never again.

Steam, Udemy, Linux Academy, and PluralSight… Forever backlogged.


#69

I don’t. The ships in that game look like ass, and the microtransactions are ridiculous.

That, and so far I like the FPS combat.


#70

Jesus, christ this is frustrating.

I load into the game two days ago and everything works fine. I load in today, and my HOTAS won’t work properly.

Like, things are completely misbound. The little toggle I use for up/down/left/right thrusters? That’s now roll and pitch. The forward backwards thruster paddle? That’s now YAW.

And the joystick itself? That now controls look and throttle at the same time.

What the fuck even is happening. Now when I try to join, the game just crashes.


#71

missions are hit and miss, I have most missions go smoothly but I did a mercenary op yesterday and one of the pirates’ ships were in the a middle of a 2km thick asteroid so I had to abandon it


#72

at any point in time did you unplug your stick/throttle? I’ve discovered that leaving my TM16000 plugged in, Star Citizen will remember my setting between game sessions, I used to reconfigure my stick every game before knowing this


#73

I did not.

I’ve tried replacing the user config file or deleting it. I tried re-downloading the t.a.r.g.e.t. file I was using, restarting my PC and unplugging/replugging my stick and throttle.

It’s fucking weird. Something seems to be resetting the keybindings at random between launches of the game.


#74

I dont use target, never installed it


#75

I’ve yet to find a way to get Star Citizen to use the stick and throttle, without it.


#76

you can bind stick inputs within the games settings
keybindings>joystick>find desired menu>click setting>activate button or stick axis

it’s all I’ve ever done


#77

Last time I tried, it only recognized a single stick.

Not a throttle and stick. I want the throttle because it has a nice 4-way joystick kind thing on the front that is great for maneuvering thrusters.


#78

I use keyboard and stick :man_shrugging:
my stick has a throttle axis in it but I use wasd


#79

I’m using this

The throttle has a nice joystick kinda thingy on the front, that is great for up down left right. Then the paddle I use for forward and reverse thrustering.

Like I said, it was working. Now it’s not.

I’m no against the idea of using just the stick, if I can use my numpad for thrusters.

Really maneuvering thrusters are my main concern. I’m terrible at parking lol.

Also slightly pissed because I wasted what little money I had on trying to to shipping, got somewhere and couldn’t land because my ship was it was apparently too big.


#80

when you’re near a pad hold n and it auto parks
press n to lower the l gear first tho


#81

It doesn’t seem to work for me unless I’m in the green lit up area within like 30 meters at most.