SSH problem

Okay I have run around in circles and I am not sure where I am going wrong. I am trying to SSH via ethernet into my Raspberry Pi. The connection is made like this computer -> router -> RPi. Every IP that I try through my computer(runs Ubuntu) by "ssh [email protected]<insert ip here>" I get either connection refused or no route to host. I think that my issue has to do with "port forwarding" but im not sure how to set that up properly. I have tried to set up port forwarding on my router but the various IPs that pop up when I run "arp -a" dont change the connection refused or no route to host. I have attempted to set up port forwarding on both my computer and RPi but I get the error"overlapping ports". Everywhere I check it says port 22 so I am not sure about that either. I am not sure what other information I need to give out for yall to help out. I just want to get this working.

a) from the raspberry pi, can you ssh [email protected], also is sshd even running?

b) from the raspberry pi, can you ssh to other lan hosts?

from the raspberry pi, have you tried a reverse ssh connection?
ie: http://www.howtoforge.com/reverse-ssh-tunneling

that is a very handy trick for your scenario given both a and b is met.

Portforwarding isnt needed when you are in the same network. So I wouldnt worry about that.

What ROM/OS are you using on your raspberry pi? It is kind of vital to know the correct credentials :)

From your diagram of your network flow let me see if I can get this straight. How is your network setup? What kind of router are you using? Because from your diagram it seem like you are trying to ssh from one network segment to another.