SSD Wiping and Migration Issues

Okay people. Major problems. I'm in the process of finishing my senior thesis project in Computer Science. Of course this is the perfect time for my PC to go down. I bought some upgrades to aid me in my project: a nice new stick of ram and a brand spanking new Samsung 840 Evo SSD. I wanted to push my project to the limit.

Long story short is that I attempted to use the built in Samsung SSD migration software to migrate my Windows 7 installation from my old SSD to my new Samsung. Couldn't possibly fail, right? WRONG!

The software failed. Of course, my Win7 installation was corrupted and did not make it to the Samsung SSD. I can not boot it at all. Good news is that I have a backup of my Win7 on a physical hard drive in the system.

So at this point i will give you my system specs as best I can from my memory (because I can't boot my system).

Intel I-5 3570k

ASRock z77 Extreme4

2X - Crucial Ballistix Elite 8GB DDR3 -1866 PC3-14900 CL9

OCZ Agility 3 60GB (We will call this SSD A)

Samsung 840 Evo 120GB (We will call this SSD B)

WD Green 2 TB (We will call this drive C)

Okay so here are the problems.

1. When I attempt to boot the Windows 7 recovery disk I get to an error when I select the partition I want to install a fresh copy of windows on: "The selected disk is of the GPT partition style. Windows cannot be installed to this hard disk space. The partition is a Microsoft Reserved (MSR) partition".

I've read that this has to do with the type of partition table the installation expects to find. It expects to find a legacy table on the drive and then hates it when it finds a GPT instance. I am not yet familiar with this type of error and have read that it is a relic of old software. Help and advice on this is welcome. MY MAIN GOAL is to get an installation of windows 7 up and running on my new Samsung SSD!

2. In order to attempt a workaround, I have tried to install linux Mint (the distro I am most familiar with) on SSD A, the OCZ Agility 3(this is mysecondary goal). Mint offers me an environment to run tests hassle free of hardware interrupts and such. However, on installation attempt, Mint will show the auto-boot splash screen and then go straight to a grey screen with a white cursor and just sit there. No go for that.

3. I have successfully booted Puppy Linux and seemed to be able to wipe SSD A, our OCZ Agility, of the old installation of Windows 7. So Puppy Linux is a resource I have.

In summary, I can not seem to install anything on my system. It seems to be expecting to be able to install operating systems in a legacy mode but my system is set to current standards. UEFI seems to be preventing me from installing anything. Before I rant on why these changing standards are making my life as a student a living nightmare, I just want to fix my issue and get things working.


1. How can I install Windows 7? Don't tell me to upgrade to windows 8 and make it good. No time right now. Maybe later.

2. Is there a setting in my bios on my ASRock Extreme4 where I can set it to install operating systems legacy wise? What are the steps? Where do I look?

3. Resources you can point me to would be welcome. I really need some help here guys. I have to have a system to run intensive tests on my Senior Project. I don't have a few days to sit around and read materials or stickys somewhere. I am asking for straight up help.

Thanks so much for reading and for any help you can give!


Nevermind guys. Problems Solved.