Return to Level1Techs.com

SSD Failed - halp pls


#1

I am not sure if all the data is gone. Here's my initial report. Will update thread with solution or whatever this means. My first SSD failure, so I am not sure if this is even a drive fail.

sys: ADATA SP900SS SSD, Win 8.1, AMD

EventLog:
Accessing a freq used media folder containing MP3/MP4, the contents were missing.
A search returned the correct pointers to the file, however no actual file itself... See image here: https://cdn.discordapp.com/attachments/249834710644162560/336434604108021760/image.png

Other dirs/folders on drive visible but contents also MIA. My paranoia kicked in so shut it down in case of ransomware - this system's worth 30USD so without hesitating I turned it back on with great pride and courage at whatever I faced. Then suddenly before me; there it was. The windows bootloader rotated the little circles for a brief moment before - A BLACK SCREEN. For a minute there was nothing. Then came a dubious Windows login prompt, everything about this screamed I was using a VM, but again, what was there to lose?
With peanut M&M's and a jar of maple syrup from the Snow Mexicans at heading FAR NORTH of here, I gave the machine my credentials, and she played along 'til I realised one of them obamadrones took a liking of my goddamn Hard Drive. I shot that thing out the sky with my shotgun. GODDAMN OBAMA DRONE. BETTER NOT BE LOOKIN AT MUH DAUGHTER WITH YUR GADDAMN OBAMADR...
[Homage to Terry Davis - talented programmer, TempleOS creator]

So the drive came up in drive manager, I assigned it GPT (I think it used to have GPT), and now it's sitting in Drive Manager as an unallocated disk. I don't want to allocate anything to it to prevent Windows from touching it further (Obamadrone....), but I assume if the drive has told windows it's empty then the drive's own internal hardware has probably done some lovely magic in the backend on it already.

Anyhow, you came for the story, I hope it was somewhat cringeworthy to say the least. Please let me know what you think I should do. Leave as unallocated? Never use again?


#2

Have you tried a Linux live distro? I've had it happen before that Windows couldn't access the drive anymore but it worked fine under Linux, re-set the partition type and showed back up in Windows.

Worth a shot at least.


#3

Why would you do that :scream:
Reformatting your drive is not the best way to go about data recovery.

Whatever you do, make a copy of the disk first. Use something like dd to copy over the entire contents byte-by-byte, not just files. This way you can experiment as much as you want without having to worry about destroying data.


EDIT: Some thoughts. Since you were able to assign GPT to the drive it's not a complete hardware failure. You can continue using the drive, just not as primary storage. Something similar happened to my HDD once and I'm still using it, but only for transferring files between PCs and other things where a loss of data wouldn't matter (as the data is still on the original PC).

Considering you could still see the files implies that your partitions were fine and 'only' the filesystem is screwed. There's probably tools around for fixing that. Not sure how you'd go about that now that you've re-assigned GPT though.


#4

You can switch the partition type without actually formatting the drive, I had to do it once because a linux install screwed my HDD (I wasn't smart enough to pull the drive before the install).


#5

Did not know that, but that's not what Windows' tool did anyway. (The drive is unallocated now after all.) I assume a special command was involved here?


#6

It was unallocated for me too, after I corrected it via gparted it worked just fine. Though I don't know if Windows does that too or if it always reformats completely.


#7

But that would require you to know the partition boundaries. Unless GParted can deduce those somehow?
EDIT: Indeed: https://ubuntuforums.org/showthread.php?t=370121

There's also be a backup GPT at the disk's end. But re-assigning GPT probably wiped that.

No way, that would take ages


@OP Take a look at deleted file recovery programs as well. The data is still on your drive, the filesystem just can't find them.


#8

I have an army to help me :smiley:
I think I explained it poorly, here's what happened https://youtu.be/xRpgjCyAUww
So right now I don't know how to access the data. If I were to try and access it with anything I would assume that whatever accesses the drive would need to format it first.
Could try a bootable USB of debian if people think that is a good idea?

edit: ok will try recovery software too - but won't that mean I need to assign the drive/allocate drive space in order for the program to see the drive?
chicken vs egg xD


#9

Depends on the software. Some only operates on a filesystem level so there needs to be a filesystem present and mounted, other operate on a block level and can recover files without a filesystem.


#10

Definitely try a live linux yes.

As @mihawk90 said, some software may need a filesystem to operate. But the last thing you want to do when recovering data is to write to the drive (which creating a filesystem does). Again, make a backup first. You can do this with the live linux.


#11

There's a bug in some older SSD's. The cure I've heard is powering it on and off. At least 10 times in a row. It can't hurt to try.


#12

agreed. formatting the whole thing only to find a better alternative after a couple of days totally sucks. i've been there a lot. especially in the red hat and lindows days :smiley:


#13

recovering this baby might get your data killed in the process. so try a linux live first to check the status of the drive or see if you can create a backup of this drive. you can also try plugging the same drive on another system but as i type it, there are very few chances of the latter working out.


#14

Yes
Gparted has an option to recover data and partitions. It will even open the drive and browse the files. And amazingly it all can be done in the GUI.


#15

Gparted is a well fledged tool. Unfortunately it sees the drive’s contents consisting of one large unallocated volume.
Even if the data is still there, I’m not sure how to go about retrieving it. apparently a live install of testdisk can read unallocated partitions, am going to see about this. apparently this happens when the drive’s partition table has been lost/corrupted /is unreadable.
Had a break from the drive but will get back to work on it later today.


#16

Make sure that before you do anything, make block-level a copy of the drive. I think gparted has a tool for it too, if not you can use CloneZilla and make a copy using DD. The last thing you want to do is accidently writing on it and destroying even more.


#17

Hi, I have no idea how to do that. Done a bit of googling and didn’t get far :frowning:
Sorry to be a pain - can you give a hand? Any chance I could get you helping out alongside me?
[EDIT] : HOLD THE TRAIN, maybe I can google some gparted tutorials etc.
Don’t help out just yet :stuck_out_tongue:


#18

No idea how to do it with Gparted, but when you boot a clonezilla live CD one of the options is a clone using DD.


#19

If you changed the partition table so the drive no longer knows where there partitions (and their data) are located, you can use the testdisk utility in Linux to recover your partitions and hopefully any data. I have done this, and although Windows no longer wanted to boot properly, I was able to recover all of the data. This was on an otherwise functional HDD, so it may or may not work for you, but it should work if the drive isn’t toast.

As mentioned, if it is possible to recover the partition data then you might want to DD the drive and copy everything over to a good drive before doing anything else involving manipulating data or booting from it. I wouldn’t do anything at all with the drive between the point of recovering the partitions and making backups. Be prepared to make a backup before you start a live CD/USB, and then make another backup of that so you don’t have to go through this again.