Speedfan showing very worrying temps (close to Tj. max)



I was watching some old Inbox.exe videos and saw Logan mention Speedfan, I decided I would check it out just to see how my temps were doing.. Well long story short.... Shit.


Speedfan was showing my CPU at temps averaging in the low 80Cs, sometimes lowering to 60C, sometimes spiking up to about 91-92C, keep in mind this is when idle, or at no more than 10% CPU usage. This has me very worried and confused at the same time. What confuses me is that in the charts it shows each individual core at only about 38-40C, which is a perfect temperature, is it not? So why then does it say the overall temperature it so high? Also I did a benchmark on ArmA 2 (quite CPU intensive) and the temperature decreased to about 50C even though the usage went from 5% to 50%, this absolutely has me stumped.


I thought that maybe there was a defect in Speedfan so I downloaded Core Temp and it didn't show any overall temperature, but it did tell me the Tj. max of my CPU is 98, which scares me. If I get this sorted within the next week, will it still damage the longjevity of my CPU? hopefully not.

Here are some useful screenshots:


1. http://i.imgur.com/7t2vzt8.jpg = Core Temp + Speed Fan.

2. http://i.imgur.com/CrxobO9.png = Speed Fan charts (individual cores and overall CPU reading)

3. http://i.imgur.com/M3f3dTh.png = Speed Fan whilst doing ArmA 2 benchmark


Here are my PC specs:


CPU: Intel i5 2500k (supposedly not overclocked)

Motherboard: Asus P8Z68 v-lx

RAM: 4x4GB Corsair Vengeance 1600Mhz

Graphics card: Sapphire 2GB 6950 (Dirt 3 edition)

Case: Fractal Design Define R4 (with good fans so no cooling issues there)

Storage: 1x Samsung 840 120GB SSD, 1x WD 250GB HDD, 1x Seagate 1TB HDD.

PSU: Corsair CX500


Thanks for any help.

OKAY I think I actually solved my own problem. I tried Realtemp and it also shows readings similiar to Core Temp and the individual core readings on Speedfan. I read up on the CPU reading on Speedfan and many people have had problems with it reading very high. Turns out it is a sensor in the CPU socket or something? so not the actual CPU. Apparently also Speedfan is quite innaccurate so this could have something to do with it.


I would delete this post but I feel that someone might get the same issue and be able to find out it's not actually a problem from this post.

use Aida64