Return to Level1Techs.com

Sony BC-U1 Battery Charger Teardown

The Sony BC-U1 battery charger/AC adapter is the standard battery charger/AC adapter for the Sony XDCAM EX cameras (PMW-EX1/EX1R, PMW-EX3, PMW-200, PMW-300 and etc)

Normally, this charger can provide DC 12V 2A out the DC cable if the switch is set to “DC OUT.”

Hmm… something’s wrong here. If the switch is in the other position, it SHOULD be a green light on the DC OUT port regardless of if the battery is in… The switch may be broken?

Here’s a working unit with the correct behavior:

The back of the unit is covered with a regulatory sticker:

images644x461

Removing the sticker, 2 T10 Security Torx screws are under the sticker. I don’t have Security Torx so I used a flathead to unpin the security pin on the screws to use a standard T10 bit.

Unscrewing the cover then undoing some plastic clips on the casing, we have our first look at the PCB, separated with a “Primary” and Secondary" compartment.

Opening up the other side, we see a cable going to the battery bracket on the top cover, and the primary power conversion components.

There is a secondary PCB handling the LEDs connected to the board:

And now, high-res shots of the PCB (camera orientation screwed up for the other side)

And finally, to those that believe it’s a misaligned switch rather than a broken switch, this is a photo of it after the teardown charging a battery while the switch is in the “DC OUT” mode. That’s not the correct behavior.

Since I’ve only done a teardown on a broken one (stuck in Charge mode) I’m not sure how the solder points are supposed to be where the switch is. When I opened it up, two solder points were already bridged.

Trying to manually bridge some points got DC OUT to work briefly, but now it just refuses to do it outright…

Anyways, that’s what’s inside this battery charger. If any electrical engineer knows how to fix it, feel free to let me know. All that happened was condensation dripped onto the switch. If it’s only the switch that’s broken it would be an easy fix, but I’m not sure if it’s only the switch, as the solder points were suspect, and I tried manual separation of the solder on the bridged points to no success.

2 Likes

Well, mystery solved. I just had to let the switch dry out. Just as I posted this thread, the switch came back to life…

Here’s the expected behavior: The battery is NOT supposed to be charging when the DC OUT mode is engaged.

Thanks for viewing the teardown anyways.

5 Likes