Something is wrong with my motherboard

Hi everybody! I need help with my motherboard.

About a week ago, I normally turned off my computer. About a hour later, I tried to turn it on and nothing happened. Just nothing. I tried to change everything - CPU, PSU, RAM, I even tried to plug in power button from different case. Nothing worked. Then, when I was unpluging ATX 20+4 pin connector, fans plucked ("plucked" - I don't know if this is the right word, thank you google translate.) and LED lights flashed. But when I again completely pluged in this connector, again, nothing happened.

So - Something is wrong with motherboard, maybe with ATX 20+4 pin connector on it. When I completely plug in ATX 20+4 pin connector, nothing happens. If I plug it only half, fans are plucking and LEDs are flashing in period of slip second, but it won't start either.

Any ideas what is wrong with my motherboard? It is ASROCK N68-S UCC (AM2+).

(Other specs: Phenom x4 9850, ATI HD4870, PSU ASUS 440W, RAM ADATA 2GB DDR2 800MHz)

Thank you. :)

Have you tried using a different power supply?

Yeah, I tried.

might help you:

http://www.youtube.com/watch?v=3ACedfiQPmE

(especially the conclusion, if you managed to minimise the threads until CPU, or either mainboard)