SOLVED Yet another "vfio not claiming graphics card thread"

Im currently running ubuntu 20.04 and i want to have a vm that has my gtx 1060 and use the intel graphics for the host. I followed the guide and got to the " Verify the isolation" section and when i run lspci my graphics card still lists nvidia as the driver instead of vfio-pci, ive looked over and over and cant figure out what i did wrong. Any ideas? heres all the files i modified:

❯ sudo cat /etc/initramfs-tools/modules
# List of modules that you want to include in your initramfs.
# They will be loaded at boot time in the order below.
# Syntax:  module_name [args ...]
# You must run update-initramfs(8) to effect this change.
# Examples:
# raid1
# sd_mod
vfio vfio_iommu_type1 vfio_virqfd vfio_pci ids=10de:1c03,10de:10f1

❯ sudo cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
vfio vfio_iommu_type1 vfio_pci ids=10de:1c03,10de:10f1

❯ sudo cat /etc/modprobe.d/nvidia.conf
softdep nouveau pre: vfio-pci
softdep nvidia pre: vfio-pci
softdep nvidia* pre: vfio-pci

❯ sudo cat /etc/modprobe.d/vfio.conf
options vfio-pci ids=10de:1c03,10de:10f1

also my grub config:

❯ sudo cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="intel_iommu=on  rd.driver.pre=vfio-pci"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Ok so i got the card owned by vfio! just added vfio-pci.ids=10de:1c03,10de:10f1 to my grub so im closing this as solved