[Solved] Xbox controller freezes games

I recieved my oculus rift and noticed it very clearly now. After a while games start to stutter, loose fps or even freeze when using a xbox controller or emulate it with scp/ds4. It only occurs if I move the sticks. Also it stabilized after a few seconds again and everything is smooth if I don't move the sticks. Sounds like a memmory leak? Buttons or triggers don't produce that problem.
And it also only appears if I move the sticks in a new direction. Pressing them to the left side for example, makes the game stutter and then it stabilize again if I don't choose a new direction for the sticks.

Very annoying. I removed old controller drivers (hope so) and plugged it in fresh. Problem still exists.
Using Windows 10 pro insider preview, latest update. Can't tell exactly when this problem occured the first time.
Does anybody have the same problem or a solution?

AMD FX Series FX-8350 8x 4.00GHz So.AM3+
2 x HD7950-DC2T-3GD5-V2
800 Watt Be Quiet Power Supply
Windows 10 Pro Insider Preview 14316
AMD Driver 16.4.2

Corsair K70
Razer Deathadder 2013

used the old version of ds4. i have the same for my ps4 with the new ds4 tool and for some reason it crashes my game. i can get it to work every once and a while.

or just buy a dongle for your controller. thats the simplest method

It doesn't matter what I use original xbox 360/one/emulated with ps3 or ps4. Currently I am using the included xbone controller with wireless adapter. The stutter still occurs

are you running on max setting? try turning some down. maybe the program uses too much memory or cpu power. it is a new program.

i had the problem when i connected my tv, but not at my desk

Afterburner shows 30% gpu use so there is room ;) Also the cpu is not the bottleneck. It has nothing to do with hardware limitations. It does occur in other games too (Rocketleague, Dark souls 3, Tomb Raider, Cobalt) So it has nothing to do with the rift. I hadn't this issue before. Things that changed (things I can remember) are just the pro insider preview update and gpu drivers updates. Seems I have to do a clean install of windows 10 stable again..

I was about to say are you running windows 10 and Uplay but you might have other stuff going on. What is your system specs?

AMD FX Series FX-8350 8x 4.00GHz So.AM3+
2 x HD7950-DC2T-3GD5-V2
800 Watt Be Quiet Power Supply
Windows 10 Pro Insider Preview 14316
AMD Driver 16.4.2

Corsair K70
Razer Deathadder 2013

Crossfire on or off makes no difference. Also I tested all USB entries 2.0 and 3.0. Motherboard ist on latest BIOS.
One thing I noticed was that my OS gets laggy, too if it occurs ingame. And after it stabilized again the screen goes black for a short period and everything is fine again. Could there be some windows aero mystery going on?

sounds like your hard drive is limiting how fast it can load stuff.

It is a SSD so sadly no. Also I deactivated cache menory on hard drive to be sure that it is not the drive. Ganes run smooth without controller. But plugged in and moving THW sticks and it stutters

have you tried lowing overclock? might want to check event log on windows

Also tested.. Resetted motherboard settings and AMD stuff to default

what does event log say?

1 Like

There are a bunch. But mainly these two do pop up very often in this timeframe.

  • ERROR DistributedCOM 10016
    Durch die Berechtigungseinstellungen für "Anwendungsspezifisch" wird dem Benutzer "NT-AUTORITÄT\Lokaler Dienst" (SID: S-1-5-19) unter der Adresse "LocalHost (unter Verwendung von LRPC)" keine Berechtigung vom Typ "Lokal Aktivierung" für die COM-Serveranwendung mit der CLSID
    und der APPID
    im Anwendungscontainer "Nicht verfügbar" (SID: Nicht verfügbar) gewährt. Die Sicherheitsberechtigung kann mit dem Verwaltungstool für Komponentendienste geändert werden.

  • ERROR OVRServiceLauncher 0
    Die Beschreibung für die Ereignis-ID "0" aus der Quelle "OVRServiceLauncher" wurde nicht gefunden. Entweder ist die Komponente, die dieses Ereignis auslöst, nicht auf dem lokalen Computer installiert, oder die Installation ist beschädigt. Sie können die Komponente auf dem lokalen Computer installieren oder reparieren.
    Falls das Ereignis auf einem anderen Computer aufgetreten ist, mussten die Anzeigeinformationen mit dem Ereignis gespeichert werden.
    Die folgenden Informationen wurden mit dem Ereignis gespeichert:
    [SetProcessGPUPriorityClass] Target process did not respond in time

It's in german. I can try to translate them if you cannot get what it describes.

In the meantime I'll try to fix the first one. The second one is oculus related. But this problem does also occur in none oculus games. So Idon't know if it is important or not

yeah that would help. i am guessing that the oculus program messes with the controller in some way. no sure how

So long story short. the new pro insider preview fixed it....
Yeah. So there is that and my night is gone. Thank you very much for helping

youre welcome.