[Solved] Windows XP - Operating System not found

Hey, so I’m trying to get this Windows XP machine to boot the OS, but I’m stuck. I actually managed to get it out of this before, by what I thought was spamming random F keys to try and get into the BIOS, but it doesn’t seem to be working this time. I think it’s something to do with Hibernate mode, but I don’t know for certain. I know for sure that the OS is there, I’ve gotten it to work before, but I can’t get it working anymore.

Any ideas?

Look up the manufacturers shortcut for getting into the bios. May have been the delete key. Beyond that make sure the all the hardware is properly installed and all the cables are seated as well.

I can get into the BIOS fine now, but I still can’t get into the OS.

  • is this a fresh install?
  • is this on XP supporting hardware?
  • what is the hardware spec?
  • have you run a hardware test? if this is a machine that came with XP, then its due for some form of hardware failure which may be the root cause of your problem
1 Like

Is the OS drive being detected by the BIOS? If not you may have failed HDD, bad PATA/SATA cable, or the something on the mobo has failed.

No, this is an old install that’s been there since like 2002.
Yeah, XP supports the hardware. I believe it’s the only Windows OS that will even run.
No idea. It’s a Compaq Presario 700 CM2130.

I don’t think there’s a way for it to detect whether it’s there in the BIOS or not. It’s an old basic minimalistic BIOS.

Is it a sata drive?

Have you tried hooking up this drive, onto another system?

1 Like

Your bootloader and or boot.ini could be broken. Seem to recall a tool called fixmbr on hirens boot cd that did the trick.

Entire drive could be failing if it’s from 2002.

I’d boot from other media and run some diagnostics.

As to being SATA or not I suspect it’s on the edge. First SATA drive I remember installing would have been in 2003-2004 or so ?

No, it’s a 44 pin IDE

I have not. I need to buy an adapter.

Yeah, that’s a good point. Run a SMART test on it and all that and what not.

Master,/slave/cable select issue?

I’m 95% sure it’s a software issue.

What makes you say that?

Software doesn’t just randomly go bad, unless its a boot sector virus and they haven’t been a thing for a couple of decades at this point.

I think its more likely intermittently and now possibly permanently failed hardware, and your luck getting in before after spamming keys was co-incidence/placebo…

Hey, I have some really good/bad? news to report.

I ran two versions of the Windows installer. One, was a ghetto factory reset, and the other was an x86 XP Home Edition ISO. Both reported/detected that there was NOT a hard drive.

This is really weird though because as far as I’m aware, I have NOT touched any of the hardware in that section too much at all. I don’t know what’s going on here, or why, but I need to investigate further.

I think I’m going to try and swap pieces with the spare that I have and try to see if I can get some kind of better configuration working/going.

I’d say the drive is dead.

It’s coming up 3x its warrantied life expectancy at this point, these things don’t live forever.




I think it’s the bridge from the hard drive and the battery to the motherboard.
Either way, replaced it with the spare parts one, and it works.

Really fuckin weird.