[Solved!] Windows 7 setup, SSD, M5a97

Hi all,

I recently got myself a Samsung 840 EVO SSD, and today I wanted to install Windows 7 onto it.

I thought about doing the Data migration, so I bought a 3rd party SATA to USB3 adapter.

No such luck however, as the software can't find my drive. I assume this is because of the 3rd party adapter.

So I went to install Windows 7 on to it.

No such luck either, as the setup fails to format the drive. It can see it, it even partitions it, but it doesn't get past formatting.

I jumped on my dad's computer and used the adapter again to format the drive myself.

It worked, and data can be transferred (I should note that it was also possible to put data on to it when I had my old HDD installed on my own machine.)

So, I went into the setup again on my machine. It copies its files, and sits at 0% for, I'd say, 5 minutes, and then it fails again. (i can't remember the exact message)

My BIOS indicates that all SATA ports are set to AHCI mode.

In my SATA ports, I have these devices in this order:

1. SSD; 2. Empty (usually my 2TB HDD); 3. DVD Drive; 4. DVD Drive; 5&6: always empty.

Do you know what I am doing wrong? Do I need to load a driver at the prompt?

Thanks for your help.

Try grabbing the samsung magician utility and run a secure erase of the drive.  Then go straight into the windows install, don't format, just tell it to install.

Thanks for the help, sadly it didn't work.

Windows now refuses to format it. Magician says my drive is "locked", but it went through the secure erase.

I tried going through the setup as you say, but again it says it can't format the disk. Is it broken?

 

EDIT: Okay, it seems to format correctly on my dad's computer (and my own) through the adapter, but not on my computer which is plugged into the sata port.

EDIT2: Formatted on my dad's computer, put it in mine and started setup. I clicked next, and its copied the files it needs. Lets see if it will install this time.

EDIT3: Nope! Failed again. I think I'm going to take this one back and get another.

So. It looks like it could be down to my mobo, as when I plug my SSD into a different adapter (an old Icy Box) it works fine. As I type I am migrating my data over to the SSD.

The thing is, the Samsung Migration tool worked fine in the adapter, but when I went to boot from it I got an error like this:

"A disk read error has occurred.

Press ctrl+alt+del to reset."

 

I'm stumped. What do I do now? I once attempted the latest BIOS update but that caused my machine to be unusable, but thanks to the USB flashback I recovered from it.

Sorry for the late reply.  What drive did you have in your pc before?  Same sata port?  I'm thinking you're probably right about it being the mobo.  The only other time I've seen symptoms like this it's been because of bad memory, but if you've just pulled a standard hdd out and thrown an ssd in, the only thing I can think it would be is the sata controller, perhaps some sort of incompatibility between the two, or perhaps it working fine at sata 2 speeds but not at sata 3?

There's certainly nothing wrong with samsung ssd's in general though.

That's alright. I have a Seagate ST3250620NS 250GB hard drive in the first port. It was in the same sata port, and I tried two others (one for my bigger drive and one for my DVD drive and it failed every time)

I think my memory is OK, I ran a one-swipe memtest on it a little while ago and it was fine, plus it was working solid in my old PC (Dell Optiplex 780).

I think all of my ports are Sata 3, how would I get them to Sata 2?


(To be honest, I might return it, and get a Crucial M500. If the problems still persist then I'll have to rule out other possibilities.)

(about the samsung part, I'll remove that. I wasn't at all happy about it not working before so that's why I posted that)

 

EDIT: It seems that someone else had a problem with one of these. By the looks of it, my mobo and Samsung SSDs don't mix. Ah well, I think a Crucial M500 might be nice. (I made a post of asking about good SSDs, and if you're reading this, I'm not ignoring your advice. It's just the cheapest and really high rated.)

EDIT2: Oh, uh, is the samsung drive supposed to come wrapped in a anti-static bag? Mine didn't, so I'm wondering if it got damaged at all once.

No anti-static bag. They don;t really need them. 

BTW, What is your motherboard model?

EDIT: Maybe run through this guide to help you install. : http://www.overclock.net/t/1156654/seans-windows-7-install-optimization-guide-for-ssds-hdds

Looks like it's this:

ASUS M5A97 (not LE) R2 (AM3+)

Looking around, seems to be a few scattered reports of this model mobo having trouble with ssd installs, but no more then usual I don't think.  Only one with a reported fix I could find was just a cmos reset.  Ideally it'd be good to be able to update your bios, but if that caused chaos last time :-/

 

I think all of my ports are Sata 3, how would I get them to Sata 2?

It's something that's autonegotiated itself.  If the drive is only sata 2, the controller runs it at sata 2.  If it's sata 3, 6gbps goodness flows. 

 

As for ssd recommendations, personally I'd say Samsung, Sandisk, Intel.  Most of my gear is running on sandisk extreme 240gb drives.  My laptop runs on a crucial M4 256gb msata drive.  You guys have some extra choices over there though, so probably best getting local recommendations.

 

 

 

 

Yea, thats the right motherboard. I'll try a BIOS upgrade again soon, maybe I did something wrong. (No image, 6 beeps last time)

The thing is though, since the 1708 update, all the others are just new processor support packs.

I haven't sent it back yet (filed a return the night after) so I'll try again with your libk, btw, thanks for that!

Thanks for all of your help so far.

Status update: Catastrophic failure.

I followed shadre18d's link, and got to the "Diskpart clean" process.

The drive was pre-plugged in, and I pressed Shift+F10.

Typed "diskpart", "list disk", and then "select disk 0" (the drive was picked up properly)

I type in "clean" and I get an error stating that the cleaning process cannot continue due to an I/O error.

I still tried setup, and i got the same "cannot format" error.

I go back and do the top steps again, in which diskpart successfully cleans the disk. Now, I know SSDs are supposed to be faster, but I don't think it can be cleaned instantly, right?

I tried cleaning again twice more, and it succeded in both.

I try the setup again and it fails once more.

Is there something else I can try? I'm on the verge of sending it back.

 

Sorry mate I missed that you'd replied further in here.  Just came back to check because someone with the same motherboard and ssd is reporting similar issues installing windows:

https://teksyndicate.com/forum/windows/unexpected-error-windows-8-installation/167422

 

As for your question about cleaning being instant, yes it is.  All 'clean' does is wipe the MBR section of the drive.  If you want a complete zero fill of the drive you need to use 'clean all'.

Okay, it's solved. I've given it a couple of months to see if it breaks, but it's not died once. In fact, it's cut my BF3 loading times in half!

The disk just didn't want to play. I know it's been a while, but just in case anyone is having the same problem, do this:

Take it back, and get a Kingston SSDNow disk. Worked first time.

It's odd, but now I've got it going, I have noticed a massive speed boost!

And to you, EvilGenius and shadre18d, if you're still following this, thanks for your help.

 

(This post is for anyone who stumbles on the problem. I sincerely apologise for the very late post mods.)

Thats good to read.

Then i will put a lock on it for now.

Grtz Angel ☺