[Solved] Win10 VFIO Device cannot find enough free resources to run | Solution - <alias name="hostdevX"/>

For awhile KVM was working fine, However now I get the error for my RTX2080 “Device cannot find enough free resources” in Windows 10. If the GPU and NIC are both active.

XML https://textuploader.com/1kqr6

That image is completely illegible. It’s been compressed heavily and the resolution has been cut down.

Please upload directly to the forum. Imgur is not a good quality hosting service.

It’s native 4k png -imgur is the best host, it’s why greenshot and most screenshot apps have a upload to imgur, native function… I was pretty sure it’s lossless…
Anyways It just says "This Device cannot find enough free resources that it can use: (Code 12)
If you want to use this device you must disable one of the other devices on the system.

I saw some similar complaints on RedHat

Well the image you linked is 640 pixels wide when delivered to my phone or workstation.

I digress, I’m looking into the actual issue at the moment. Haven’t seen it before.

Thanks for looking into it. I found a few complaints, but no useful responses if any. :frowning: None of them were related to my issue either. As the GPU pass-through is working if I disable the NIC

That’s weird; pretty sure Imgur is lossless, they also never expire images[delete them], though the user gallery has a maximum amount[can’t find it unless you have a direct image link], if I have a link from an image a decade ago it’s still there!
image

So I’m not finding any useful information either.

Sometimes nvidia GPUs are unhappy with a vendor_id that’s not 12 chars long. Try the following:

      <vendor_id state="on" value="1234567890ab"/>

Didn’t seem relevant as the issue is not the GPU pass-through there’s some device limit in virt manager or windows.
I have tried your suggestion however, there is no difference.
It’s probably an issue related to Windows…
I will try another clean install when I get time to play around with this again… - quickly launching an older .img same issue.

I solved this issue recently by making the bus that the card was on for real – 0a in my case instead of 04

If you provide your full virsh edit domain xml I can show you what I changed.

It might also be useful to see irq assigned to the card and device manager in view devices by connection mode

1 Like

It’s lossless in a normal browser. The probably fucked around with it for his phone.

It sounds like the kind of error you would get if you have a limited number of MSI-X interrupts available.

Is that not what you’ve requested?
Anyways setting the bus to 0x0a didn’t fix the issue. I kept randomly changing the buses and getting several different errors in VMM after randomly messing around with buses VMM added [to 3 depending on the function] by itself; now everything seems to work again. This was not in my original XML that was previously working… IDK why there was randomly any difference in functionality.

I’ve been trying to share Filesystem with VM is how I started running into this issue. I disabled the FS and was still having the out of resources issue. So still need to figure out how to add a filesystem without this issue.

Thanks. Love yours news, whilst walking my dog and thanks for supporting so many people.