[SOLVED] Weird Power on / off issues with Asus P8H61-M (i5 2500k)

Hi guys,

I built a PC for my brother with the following specs:

  • CPU: Intel i5 2500K
  • MB: ASUS P8H61-M EVO (Bios Version 4061)
  • PSU: EVGA ATX 2.3 500W (100-W1-0500-KR)
  • Case: Fractal Design Core
  • RAM: Single 8GB Stick by A-Data
  • GPU: Zotac GTX560 OC

Unfortunately, it does have some very weird issues.
At times, it randomly shuts down (happened at idle).
Other times, it simply won't turn on. The LED on the motherboard is green, the Power Supply works and also the case button / switch for power on is working fine.

First I thought this might be a PSU issue, however I ran load test (CPU and GPU at max load) and everything ran fine (temps were also OK).
Also, I checked that all connections are as good as possible.
Next I checked for newer BIOS revision, however I am already running the newest version (4061).
Finally, I even swapped the BIOS Battery on the board.

When this happens, all BIOS settings are reset. After I get the PC working again, I get the message to "Press F1 to recover BIOS settings".

Does anyone know why this is happening or how to fix it?

I'm really quite lost here - not even the slightest idea?

This might shed some light on it...

4 x DIMM, Max. 16GB, DDR3 1333/1066 Hz Non-ECC, Un-buffered Memory
Dual Channel Memory Architecture
Supports IntelĀ® Extreme Memory Profile (XMP)
* Hyper DIMM support is subject to the physical characteristics of individual CPUs.
* Refer to www.asus.com or user manual for the Memory QVL (Qualified Vendors Lists).
*
Due to Intel H61 regulation, when install four DIMMs to form a
dual-channel operation, only DIMMs of single-sided are supported.
* If four DDR3 1333 MHz memory modules are installed, the maximum memory speed will be limited to 1066 MHz.

I may be mistaken but you need RAM in pairs for that board to work correctly, but I could be wrong.

So I finally found the issue:

I had given up all hope and ordered a different motherboard. Upon swapping out the CPU from the old board to the new one I noticed all small irregularity on the socket. Having a closer look at the socket revealed that one of the Pins (or springs) was slightly bent, another one was totally bent.

With a lot of patience (and the right tools) I managed to fix those pins. Now the motherboard (and CPU) are running perfectly fine. I guess whenever the PC tried to access a specific function of the CPU, there was either a shortage or no contact at all, resulting in a crash.

TL;DR Fixed the issue by repositioning the bent pins on the socket.