** Solved ** Warcraft 3 retail battlechess set installation

I own an original Warcraft Battle chest ( includes Reign of Chaos and Frozen Throne battle) and was able to install ROC just using the " open with wine Windows Program loader" option via rightclick on the installation.exe file

However, No matter what folder I put the installation.exe file of Frozen Throne, it keeps popping up with the WC3 pop up window telling me I must buy ROC.

The same result happens regardless of the wine prefix location being the same as the successful ROC installation or a different prefix or different installation location attempt and also regardless of using Lutris too.

How do I get my Mint 19.1 cinnamon 64 bit system to get the Frozen Throne installation wizard to recognize that I already installed ROC? I’ve googled this and keep hitting nothing but air on this one.

wine --version is 4.0 but I have multiple installing using Lutris if that matters

I thought about just doing a Windows 7 or newer VM be it Virtual box or Vmware but can’t even get VMware to the point of just launching it TO set up the vm, and can’t figure out how to passthrough my rx 580 8GB vid card to it with trying to use my older r7 270 amd vid card on the linux host machine.

Tried Chris Titus tech’s instructions but terminal keeps saying iommu functionality is not available

cpu 4790k VT-D IS supported…check
mobo asrock z97m pro4 supports VT-D check and I ensured all things involving virtualization are enabled ( VT-D…hyper v, as well as the igpu for kicks n giggles)

All vga output devices ( rx580, r7 270 and the intel igpu) are showing up with lspci …whatever as they normal should

Ideas? I’d prefer to figure this out natively without dealing with a VM if possible. So far this old but great classic game is the only one giving me the hassle.

Man…no body? I was thinking someone would know. :frowning: I really would rather not have to buy the " reforged" redown WC3 deal and have to deal with logging into battlenet JUST to play a game I already bought a retail legal legit copy of just to be able to play it in Linux.

Guess my original point stands. redeem your keys on battlenet and try the digital installers instead.

use the new Lutris Script for TFT with the new digital installers. This sets up battle.net (now required for classic titles using the new installers it appears) on a 64-bit prefix.

(Still testing: The new digital installers seem to just install both, though i have both installers in the same folder.)

Installing, need to have the battle.net client running to have a working update agent. (installed with the newest Lutris Script for TFT)

Update: Takes a lot of fannagaling to get the serial key box to show on first launch for ROC, but running in an emulated desktop and waiting seemed to help. game does boot with FMV. Working on getting TFT installed.

TFT is bundled with the installer even though it loads up ROC. just switch between expansions with a toggle button next to the SP menu option.

Works great, though I’m having my own set of problems with nvidia_DRM soft locks while just running this. Pretty sure it’s my config + this game and not wine.

1 Like

Ok I’ll give that a shot this weekend. Thanks for the details.

Yeah I tried that and I am stuck at this infinite stupid small black background window that gives option 1 to play the ROC campaign. I type 1 it reloops instantly back to asking what I want to do. F U BLIZZARD!!! THis is sheer B#%%t !!

I’m currently using Lutris with wine stable and staging versions 5.something 99% of all my other games just work.

I’m seriously tempted to just see if even my igpu in 4790k is enough to play wc3 battle chest in a windows xp or win 7 virtualbox . (sigh).

Thank you for the info/suggestion though

Blizzard nuked the old client, the old games and ‘reforged’ use the updated ‘reforged’ version.

Yeah, WCIII in original form pretty much doesn’t exist anymore. Just Refunded edition… and it looks so awful… and it doesn’t even seem to work properly…

1 Like

#$%k me then. (sigh). So I’m forced to use a damn VM just to actually play the game as I originally could when I bought the retail two disc version back in 2003? ( which is LOCAL storyline campaign.not online…not multiplayer…)

" You guys h ave phones…right?" Yeah…we also have the ability to KEEP our money where it belongs…actiblizztards…AWAY from you. -_-

Seriously I’d have no problem sleeping if someone brass knuckles wearing hitman would visit the moron in blizzard that made these decisions.

1 Like

I mean, I run a Gaming VM now that it’s working mostly proper. but yeah… unless you have your original discs and don’t intend to play online, you’re kinda stuck with the refunded client.

That’s just it. As I said before I’m trying to run the games from the original retail Battle Chest two disc game set I bought back in 2003.

Well, the CD installer for TFT was updated about 2 weeks ago on lutris.

Yeah I tried all of them. Shows me two months 3 weeks ago per https://lutris.net/games/warcraft-iii-reign-of-chaos/ (shrugs).

Either way I’ve hit a wall for now. But, (shrugs), I’ll take a short break from trying wc3 battle chest and get other games going. So far so good. I have literally every single other game ( except for this one then one other I couldn’t care anything about) going with the exception of around 5 to 10 left out of a total of 40 something.

I’m seriously hyped. For the first time I feel real hope in finally being able to flip the bird loud and proud at micro#$T windows forever.

*** Update 3-16-21 ***

I got it working finally .and it just took doing ONE…stupid…thing.

Renaming the “Movies” folder to anything other than just Movies ( even adding a dot at the beginning or end or whatever) will ensure the game doesn’t crash on launch ( both ROC and TFT)

There is something about the cut scenes that Wine just refuses to deal with or properly. Renaming that movies folder will ensure they don’t auto play when they are supposed to…aka won’t auto play period. So essentially, it cuts the movies out of the game

If you want to watch those cut scenes…you must navigate to them in your file manager and launch each one via whatever video player app you have.

Yes…this sucks but whatever at least the game finally works

Wine 6.3 staging
Newest mesa and vulkan as of 3-16-21
LM 20.1 Cinnamon 4.8.6

5900x cpu
rx 580 8GB sapphire nitro+ vid card
asrock taichi x570 mobo
32GB of crucial ballistic ram running at 3200mhz 15-15-15-21 timings
Intel 750 800GB ssd for OS install
4TB samsung 860 sata ssd for games, etc including wc3 battle chest set

Just use Wine to install ROC, then try to launch it ( doesn’t matter if it’s within the end of the install wizard or separately via file manager), it will crash and probably change the gamma of your desktop and of course the rez to 800x600.

Then fix all of that back to normal

Now navigate to that Movies folder and rename it to where it is different regardless of how.

Now launch the game and it should work.

Next if you’re running a reasonable modern day resolution ( such as 1920x1080 or higher), you’ll notice the highest built in rez is 1600x1200 by default in the game’s in game graphics settings menu.

Windows registry edit is next

So open the correct folder ( I forgot if it’s the one where .wine is located…aka within that folder…OR if you must navigate to the Warcraft III folder that was created during the install wizard ), and right click within it in an empty area to select " open in terminal)

now run command without quotes " wine regedit "

You’ll need to navigate in that through Local Machine, software, Blizzard Entertainment,and you’ll eventually see Warcraft III and then Video, ( not the cut scene one) but you’ll see Rez width an rez height. You’ll need to double left click on each and chance the Decimal values to match your monitor’s rez or whatever other rez you want.

Then close that out, and launch the game again. It should work.

NOW…you can install TFT disc and no further tweaking is needed.

My thanks to user 1000 on Linux Mint forum site for this

" Re: Warcraft III Original 2 disc retail Battle Chest game set through Wine?

Post by 1000 » Mon Mar 15, 2021 9:38 pm

I found only one result on the internet
https://tipsfor.us/install-warcraft-3-o … sual-guide "

Hope this helped anyone. Cheers –

Woops, sorry I hadn’t seen this.

I got the same thing, haven’t tried installing yet tho. Bought it then shelved it lol. I can try an install for you later tonight.

My first words of wisdom though… Please use anything but mint? For me? <3

“I can try an install for you later tonight”

I’m confused. Did you take my most recent comment as me saying I haven’t resolve the problem yet? Because that isn’t the case.

I got it working now. Just had to rename the stupid Movies folder to something slightly different. Wine runs it like a champ now. :smiley:

Oh, sarry lol didn’t see

There’s a problem solved button for a ceason dude

Well it’s been a long time since I was on here and I cannot find that button. Where is it?

1 Like

Huh.

Should be a button for you. Actually legit question now, why isn’t that button appearing for my guy.

@wendell

Ah No. Linux Mint is rock solid and has never given me any problems or often enough to worry about switching to another distribution. And in case you’re eluding to Arch…not no but hell no. I can never actually reach a GUI…USABLE desktop.

I’m not a brain-dead appliances only normie…but I don’t have another 6 decades to worry about which character our of thousands I typed that must be corrected just to reach a GUI desktop when setting up Arch properly. I’d rather try counting grains of sand on a beach.

Linux Mint is the main reason I was able to finally move away from winwoes 100 percent and couldn’t be happier.

1 Like

Ew no I’m not going to yell a meme. I just have 0 trust in the mint devs.