[SOLVED] Unable to keep running Looking Glass Host program under VM Windows 10


I run successfully a Windows 10 VM using KVM 4.0 and dedicated video card pass-through under Ubuntu 20.04
The nVidia K4200 is connected to a second monitor and is running well to display Windows 10 desktop.
I compiled the Looking Glass B6 code and it is running without issue.
I installed the B6 Looking Glass Host software under my Windows 10 virtual machine

However, when I execute Looking Glass (host) software under Windows 10 (10.0.18363.418), the application appears briefly in the task manager and disappears.
As a result, the looking-glass-client application shows ugly Windows 10 desktop and it always complains :
[I] 15482400209 main.c:1468 | lg_run | The host application seems to not be running
[I] 15482400258 main.c:1469 | lg_run | Waiting for the host application to start…

I did the most complex part of the installation but the issue seems to come from the easiest part : running the host application under the Windows VM!

Any idea to solve this ?

Thank you!

Config :
Dell Precision T7810
1300 W power supply
2x Xeon E5-2690 v4
256 GB memory
nVidia K6000 graphic card
nVidia K4200 graphic card (pass-through)
nVidia Tesla K80
5 TB on NVME / SSD
Ubuntu 20.04
KVM 4.0

The Windows host installer installs the host application as a service. You’re not supposed to run anything. The service will start the host application automatically once Windows starts. See the LG Documentation - Install host service for details.

Thank you for this remark. I found the service in the admin panel. The service LG host is not started. When I start it, after few seconds, it goes back to stop state. In the meanwhile I received another graphic card : AMD Radeon WX 3100. I uninstalled the nVidia K4200 and replaced it by the Radeon with its Windows drivers. After restart, LG host service is constantly in started state. LG client is now working like a charm and I see the high rate screen refresh as expected.

I have no idea why LG host service could not start with my nVidia K4200. As I want to keep the Radeon for other reasons, my issue is now solved.
Thanks again.