Return to Level1Techs.com

[SOLVED] Ubuntu 18.04 Lutris, graphical errors on menu


#1

Specs: Threadripper 1950x Vega 64 ubuntu 18.04
glxinfo: (I do have the MESA drivers installed)

server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL core profile version string: 4.6.13536 Core Profile Context
OpenGL core profile shading language version string: 4.50
OpenGL version string: 4.5.13536 Compatibility Profile Context
OpenGL shading language version string: 4.50
OpenGL ES profile version string: 4.5.13536 Compatibility Profile Context
OpenGL ES profile shading language version string: 4.50

I have done the following guides and fell down a few rabbit holes to install the MESA drivers as well as the VULKEN drivers:

So now that the information part is over, I installed Blizzard battle.net and all I see is the following link https://imgur.com/a/P7fAGvS .

Sub-menus work on the blizzard.net. So I uninstalled it and tried out Overwatch, same issue. Graphical errors. I also tried the Witcher 3, same issue as well. I can’t figure out how to fix this one. the games crash the computer when forced closed, but not when I quit (if I can find the button to quit that is). I am able to play steam linux games.

looked at the logs for Lutris when running blizzard battle.net:

wine: cannot find L"C:\windows\system32\winemenubuilder.exe" ATTENTION: default value of option mesa_glthread overridden by environment. libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: radeonsi ATTENTION: default value of option mesa_glthread overridden by environment. mesa: for the -simplifycfg-sink-common option: may only occur zero or one times! libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: radeonsi ATTENTION: default value of option mesa_glthread overridden by environment. libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: swras

any ideas?

Thanks for the responses!


#2

Try the pkppa Padoka stable instead of the bleeding edge one:

https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/pkppa/


#3

Thanks for the reply,

I purged the mesa drivers and installed the one you suggested. still didn’t work :confused:

same wine errors as stated above about the application.


#4

You may need a newer Kernel. Try Kernel 4.17.3 by using Ukuu.


#5

reverted the kernel (I was on v4.18.12). graphical bug still present.
the Lutris log still says the following: ATTENTION: default value of option mesa_glthread overridden by environment.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
ATTENTION: default value of option mesa_glthread overridden by environment.
mesa: for the -simplifycfg-sink-common option: may only occur zero or one times!
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
ATTENTION: default value of option mesa_glthread overridden by environment.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast


#6

Have you followed the instructions here?

Not trying to be condescending, just trying to rule things out.


#7

it’s fine! I don’t feel like you are being condescending, let me give it another shot! maybe something got lost in the fray.


#8

SOLVED: I installed the pro variant from AMD.


#9

Good job on getting it working!