[SOLVED] Trouble with usb 3.0 hdd enclosures on linux

I have a long-standing problem with a 4-bay enclosure from Startech that is supposedly OS-independent. All drives are recognized, and when the software for the mobo is loaded on Windows the drives access just fine. However, in either Windows without the drivers, or in Linux (only usb 3.0 native kernel drivers available), initial drive access can take up to 30 seconds. The system sees the drive and can navigate the folder structure, but when I try and do something like play a video it lags as described. Thereafter it works just fine — unless the drives go idle for a while, then it does it again. This only happens with USB. My eSATA connection works just fine with drivers installed on Windows (but not without), and flawlessly on Linux.

I’m looking for either a solution for this specific enclosure or a tip on a different 4-or-greater-bay enclosure that any user here knows works on both Windows and Linux without such problems.


cpu: i7 8700k
mobo: ASRock Z390 Taichi Ultimate
memory: 32 gig
enclosure: StarTech S3540BU33E
os: Linux Mint kernel 4.18/Windows 10 1809

SOLVED: used sdparm to clear the STANDBY field on one disk, so the disks don’t spin down.

1 Like