[SOLVED] Tried hardware passthrough but didnt work out that well

Hi, I tried to do GPU passthrough today. Did everything as described in @wendell's post. Well, I didn't blacklist the Radeon driver, but as I use a AMD GPU as my Linux GPU, I thought if I did this Arch wouldn't give me any video output (correct me if I'm wrong on this one).

Then I proceeded to create a VM with virt-manager and installed Win10 over the VNC, which worked great, then I passed through my RX480 and nothing happened. As I tried to turn my VM off again my PC crashed. If you need any log files, just tell me how I get them and I will post them.

newest Arch-Linux x64 with systemd bootloader
CPU: AMD FX-6100
RAM:some 16GB Corsair Kit (2*8GB)
Mobo: Asrock 990fx Killer Fatal1ty
Linux GPU: R9 270X
Guest GPU: RX 480

If you never installed the proprietary amd drivers it should just be as simple as passing through the second gpu, without blacklisting anything. Did you install amd drivers on linux?

Yes, I did install the xf86-video-amdgpu driver. Can I just uninstall it and it works?

Edit: uninstalling the driver solved the crashing. But the the guest GPU still gives me no signal

Got everything working, changed the efi vars to the https://www.kraxel.org/repos/jenkins/edk2/ efi vars and now it works.