Return to Level1Techs.com

(SOLVED) Stubborn computer refuses to install OS

hello everyone. thanks for checking this thing out with me.

so i have a system that i’m trying to re purpose for a retro windows xp gaming pc.

the hard ware is:
700watt thermaltake smart PSU
fx 8350 CPU @ base 4ghz
16gb DDR3 1866mhz @ 1600 mhz
Gigabyte 990fxa-ud3 Rev 4.0
1TB 5400 RPM HDD
GTX 560 TI GPU

the problem is. the system has failed to install all OS’s i have tried.
this includes:
windows 10 64bit
windows 7 64bit
windows XP pro 32bit
linux mint 64bit V 19.3
ubuntu 64 bit V 18.04.4
i have tried all by USB flash drives ranging from 16GB, 32GB to 256GB.
I have burned DVD’s and tried old school methods.
the best i got was windows 7 “installed”, tried to restart and failed to finish, on dvd, just black screens with flash drives.
i have tried to change the bio’s settings from uefi to legacy and any combination i could think of to get passed this.
the motherboard doesn’t have a secure boot option so i couldn’t disable that as i tried to do research to the problem first. i’ve been shoulder deep in the computer scene for the last 22 years and this is the first time i’ve had all known good parts to fail installing an OS on a drive that is good and detected.

windows XP claimed there was no drive detected once it loaded up. windows 7 found the drive no problem.
linux of all flavors gives me a " (initramfs) unable to find medium containing a live file system" error with or with out the hard drive plugged in.

i’ve never had linux fail to boot a live instance like this.

if anyone can shed some light, i would be very grateful, thank you!

Perhaps there is an issue with the drive, power, sata cable, or sata controller. I would try to put a drive into another machine, install Linux (check iso hash first), ensure it works, and then move the drive over to the other machine. If it still fails even after trying a different sata power and data cables and a different sata port (changing bios boot drive) then it might be the controller.

I’ve had a few machines refuse to boot from USB but usually a dvd worked. I haven’t used optical drives in a while, so I just prepare a drive in a separate machine if I come across that issue.

2 Likes

The motherboard is in working condition as it was just pulled out of service to upgrade to a ryzen 2600 set up.

The drive is also good as it was a replacement for my laptop from acer but in the meantime while waiting on shipping I upgraded the laptop to an ssd. So I used it as an external drive until I started this project. It has very little on time. As an external drive it works perfect producing about 189 mbs transfer speed with no spin up issues.

The power supply was just bought new from best buy for this project.

The sata cable was bought from microcenter, however I never used it and the times I’ve tried, I’ve not been able to get it to work. However in its defense, when I have switched sata cables, I found the cable to not be the problem but I never put the cable back into service after the fix. So that’s an iffy.

I have tried different power cables. I will try a different sata cable. What really gets me is Linux won’t boot into a live version with a disk or USB drive.

The drive has been sitting in sata port 0 out of 6. I will move ports when I switch cables.

Thank you for the suggestions and I will look into them.

Did you wipe the drive fully? You may want to boot some linux stick and do a good format of the full drive. Clearing CMOS maybe?

Is it a prebuild? They have maybe sneaked in some recovery disk somewhere?

You may want to check your iso’s and burning tool. iso’s can corrupt and tools sometimes have bugs. Rufus is what I use on Windows, this is really reliable.

i have used rufus and etcher both with the same results. imgburn for the discs. i have been coming at this from the windows side. windows 10. i’ve thrown linux in the mix purely because i know it has no need for a hard drive if things get tough. however it’s also stuck.

switching sata ports had no affect.

the system is custom built as are all of my desktops. (built myself)

i did wipe the drive as an external drive using windows drive manager instead of just quick format.

i have used many different flash drives and dvd’s in this attempt. i have a whole bag of flash drives ranging from 16gb to 256gb usb 2.0 and 3.0/3.1.

i have not cleared cmos yet. i figured it would have little affect to the situation.

now there is a second piece to this puzzle which i’m unsure on how it comes to be. but linux will share this piece of information with me.

device descriptor read/64, error -32
this is for the usb ports. it apparently is failing to read all of them, front or back of the computer.

i don’t understand this behavior because the bio’s detects everything thats plugged into them.
to note on top of this, the dvd drive is also usb.

i’m not sure how windows 7 was able to use the usb ports to install windows before the restart and fail to follow through to the desktop.

i don’t know if this helps any or not but the usb ports were working before we removed the board from service. all of this has happened with in the last week. all the upgrades and component transfers.

thanks for any help toward the resolution of this problem.

USB can be broken by a single damaged port/cable. Try checking each port for physical damage and cables, connectors for wear and tear.
You can also install the windows in a VM on a different computer to avoid USB issues.

i’ve ran vm’s for windows xp. sadly many games require the hardware windows xp to work. thats one of the driving forces for this. i have some favorite games that are broken in VM’s.

i will double check the usb ports. thanks for the suggestion.

(edit) i checked all usb ports. they are all in good condition. i cleared cmos and checked all the cables inside the computer. everything looks good.

(edit #2) i tried removing the front panel usb and audio in case the old case i used for this project was the problem.
still failing to read usb.

after i get this screen, the computer becomes unresponsive and i have to do a hard shut down or flip the power switch to recover.

Try on or off IOMMU in the BIOS and edit Grub

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash iommu=soft”

As a fellow poor-dozer owner, this is an IOMMU issue. There is a issue with the last bios update for the 990fx (I have an ASUS TUF edition) that requires you to turn off IOMMU for proper USB XHCI support. Or you can turn on legacy support for USB and turn off the USB3 functions since this will be a retro box.

Otherwise, what @TimHolus said will work.

So I did find iommu. It was turned off. I turned it on and Linux the Ubuntu flavor, 18.04.4 was able to install. The bios is acting a little weird with it though and there is a bunch of page faulting before Linux gets loaded up. But Linux is working.

I tried to install Windows xp next and it hasn’t changed. It’s still just a black screen with a white blinking cursor. It will stay like that for hours if left alone.

you may not be able to install xp on this system because xp probably cannot detect or support the newer hardware.

ran into the same problem when a customer tried to install winnt in a large hard drive they bought for their old server.

windows xp supports hhd’s up to 2TB. the ram won’t be fully utilized in 32bit but the motherboard has chipset drivers for windows xp. i was actually suprised to see such a new board with drivers for windows xp. but i checked that before starting this project.

i haven’t been able to get any windows versions to work, not just windows xp. the core count shouldn’t be a problem because i’ve had phenom II x6 on xp before.

AHCI on or off in bios, check IDE?
SATA drivers added to XP?
XP SP3?
The keyboard / mouse is USB or PS2? If usb then try without or with PS2.
RAM is ok?
Delete all partitions from hdd / ssd.

hi thanks again for trying to help.

windows xp is pro 32bit SP3
not sure if sata drivers are added.
ahci has been both on and off.
the bios has a ide mode for all sata ports and ive tried that.
keyboard and mouse is usb.
ram is good and detected. it’s gskill sniper series full matching set.
i’ve tried from a completely blank HDD.

now to rule out windows i tried installing windows 10 64 bit.
windows “installed” but failed to restart into the OS and tried to “install” again.
when i checked the hard drive through the second install attempt, the hard drive showed several GB missing which seems to be windows as it’s the only thing it could be since i wiped out ubuntu. but now ubuntu is stuck in the bios as a boot option even though i deleted everything with the first windows 10 install.

i did try to install a second time and windows seen the other version of windows giving me the “everything will be moved to windows.old” message.

i have not tried windows xp with ps2 only. i do remember back in the day that had to be a thing to get the OS to respond to inputs. but i don’t remember it keeping the OS from loading.

thanks again for all the help.

So i have an update on this system. there were several contributing factors.

the bios has been changed to pure ide mode for all ports and the sata controller.
i had to use a disc for windows xp to load.
windows xp did play nice with the USB keyboard and mouse but does not like USB 3.0 with or with out drivers.
the biggest contributor to making the system work was swapping out the sata cable. apparently the one i was using was defective. so it’s found it’s way into the trash. i’m not sure if the length had anything to do with it but it was a 3 foot sata cable. i thought i read somewhere that 18" was the limit.

in any case the system is up and running like it should, nice and quick. thank you all for helping with this project! i’m actually posting this with the XP system.

1 Like