[Solved] QNIX UHD 4020R HDMI 2.0 port problems. limited resolutions

I don't know if anyone else has this monitor but maybe someone has had similar issues with other Korean monitors.


The Problem:
So basically what my problem is, my HDMI 2.0 port is not working correctly. Plugged into my PC(GTX 980) or Chromecast Ultra it takes an input of 1280*[email protected]


This is after I broke it somehow.

Before I have plugged in a PC in the past and got 3840*[email protected] on the HDMI2.0 port though I didn't used a HDMI 2.0 cable.
With the Chromecast Ultra he HDMI 2.0 never did 3840*[email protected] before properly(it would be missing 2 horizontal pixels so 3838*2160, which would cause this line across the screen in random places every time I switched sources).. I never tested HDMI 2.0 off my PC before I had my problems unfortunately.
What I did to sort of fix the that problem was set the Chromecast to 50hz and the 2 pixel line across the screen would go away though it would still show 3838*[email protected] in the menu.


What happened:
Okay so what I did to break it was I had both my PC plugged into the DP1.2 and the Chromecast Ultra plugged into the HDMI 2.0. While have the PC as the main display I activated PIP for the first time with this monitor. This is where everything got weird. So it went small and I watched an episode of Seinfield on the PIP screen which using my computer. When I went to play around with PIP setting I swapped the screens and the little PIP screen actually reduced my PC resolution to 1920*1080 BUT my Chromecast was a tiny little box in the middle of the screen at 1280*720.

I then turned off PIP and set the Chromecast as the Input Source only and it was still a little box 1280*720 in the middle. Okay so this was weird, I turned my TV off and on, restarted the Chromecast. Still the same. I then pressed reset in the TV menu and the Chromecast went back to full screen BUT it was still 1280*720. Nothing fixed. I later figured my aspect ratio must have just been 1:1 before I reset the settings so this paragraph is mostly irrelevant.

I now have an HDMI 2.0 cable so I plugged my PC into the same port the Chromecast was in(HDMI2.0) and only got 1280*720 as an option in the display settings. I tried Custom Resolution but it just showed nothing.

The problem is also unique to the HDMI2.0(HDMI1) port only and HDMI2, HDMI3, and DP1.2 are working perfectly normal.

I've tried looking for this problem online but couldn't find anything. Since the HDMI 2.0 didn't work with the Chromecast Ultra properly to begin with the TV might just have some fault unique to my unit. Or maybe just this model specifically but just hardly anyone has it and done exactly what I did to have this happen to them.


IMAGES:
Chromecast Ultra HDMI1:


Chromecast Ultra HDMI2:

EDIT: First time using these forums, don't know why the formatting is so weird.

okay so i have figured it out.

I finally gave up after trying to fix it the past 5 hours.

I sat back on my chair and just decided to watch stuff in 1080p.

I then for some reason decided to flip through all of the PIP/PBP modes with JUST the Chromecast connected into HDMI2. Then something sparked in my mind and I thought maybe flipping through ALL of the modes reset the something for some reason since it cause it in the first place.
Bam, HDMI1 is back to working at [email protected] again with the Chromecast Ultra. It is a miracle.

I can even recreate the exact situation again and get HDMI2.0 port to limit itself to 1280x720. I then tried to switch through the PIP/PBP modes WITH the computer plugged in and on(displaying content) and Chromecast in HDMI1 at the same. time but it does not reset it to 4k.
So I had to plug the Chromecast into HDMI2 then flip through the PIP modes then plug in back into HDMI1 again and 4K worked again.

this thread can be closed now but anyone looking for a solution if they acidentally cause it themselves.

1 Like