[Solved]Proxmox hw passthrough sched_error 20

I followed this guide. And I get error output for my gpus passthrough.

1 Like

Are you sure step 4 worked?

Step 4: Blacklisting Drivers

We don’t want the Proxmox host system utilizing our GPU(s), so we need to blacklist the drivers. Run these commands in your Shell:

echo "blacklist radeon" >> /etc/modprobe.d/blacklist.conf
echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf
echo "blacklist nvidia" >> /etc/modprobe.d/blacklist.conf

And lspci -kv on the GPU to ensure nothing loaded/in use?

what would the output be for vga? if it didnt load?

lspci -kv

1 Like

Cool, the bit that says “kernel driver in use:vfio” confirms you successfully isolated the device, which is good.
But also means something else is calling nouveau, and erroring, which is less good.

Do you know what is at :10.0?

Like,

lspci -v -s 0000:00:10.0

In case it is complaining about something at that address, causing the errors? (Presuming that is the pci address, not some other reference… though thinking about it, not sure the .01 is normal for pci )

I believe it is the hdmi audio part of the video card.

1 Like

It looked like that bit was covered, in 0a:00.1 in the second screen shot you posted.

I mean, it would be great if it were, but didn’t look like it, to me.

Looked like you did the right thing, isolating both GPU(0a:00.0 and sound at 0a:00.1)

image

not cut off that is all the output for that device.

1 Like

The top left is the pci address bit

But apart from the -s check above, not sure how you could check what’s calling it.

There might be some lsof command, but not sure if that extends to drivers, or just files/apps/ports

1 Like

I really cant do anything at present with restarting my pve instance. my mom is using it at present to teach her class. She doesn’t have internet so she comes here to do it. pihole is a vm on proxmox.

I am free to work now.

I may need to reflash the bios on the gpu. my 1050ti works fine, quadro has issues.

1 Like

Oh yea I got it fucking working bro.

1 Like

Noice One Son!

Tonemapping is a no go. Only works in docker. strange that it works in docker but not in the non container format.

That is odd.

And I am annoyed I didn’t consider the fist (error messages) were from inside the client, and the second shot (pcie verbose output) was from the Host.

And very odd; I would have guessed the other way round too.

I had to disable noveau at boot in grub. that fixed the issue.

1 Like

Disabled in the container, as well as the host?

VM, i am doing vm not container. but yes on both.

1 Like