[SOLVED] Problem booting Debian on ZFS

Hi there,

I’m trying to install Debian Jessie 8.8.0 on a ZFS root filesystem, following this excellent guide. I followed these instructions very carefully multiple times, making sure each time there were no errors. However every time when I try to boot I’m presented with the error “NO OPERATING SYSTEM FOUND”.

I’m doing this on my laptop, an Acer TravelMate 8473TG. Specs:
CPU: Core i7-2640M
RAM: 8GB DDR3-1600
GPU: Intel HD Graphics 3000 w/ Nvidia GT540M Optimus
SSD: 240GB Intel 520

I’m using the (un)official Debian 8.8.0 Live DVD with non-free firmware because of networking… oh well.
One of the main issues with this laptop is the fact that it has UEFI-BIOS, but is NOT able to boot any live medium or operating system in UEFI mode. Although it will try, it can only boot in legacy mode. I guess this is an incomplete UEFI implementation on Acers part? Anyway, I followed the instructions in the guide for legacy booting, no errors of course, and every time I get the above message.

My limited Linux knowledge does sadly not allow me to progress any further. After a few days of googling, I’m more familiar with the way grub should work and handle this, but none the wiser as to debug this error.

If any of you have any idea what could be wrong, given that I had no errors show up following the guide, any help would be greatly appreciated.


1 Like

I might not be of great help as i have never booted from ZFS myself, but i’m interested. Why are you trying to get ZFS running on a Laptop AND boot from it? From your description you only have one drive. What benefits are you expecting from using ZFS in such a setup?

EDIT: heck, why is this one year old Post on top of my “Latest” view? Sorry for Necro Bumping that one…

1 Like

Well, since we are here anyway, I might as well add the solution I found:

The problem was that I wanted to boot from GPT partitions, but since the UEFI implementation on my laptop is broken, it tries to boot in UEFI mode if it sees GPT partitions, even if only a legacy bootloader is present.

The solution was to create a hybrid MBR as described here: http://www.rodsbooks.com/gdisk/hybrid.html

I now boot Debian 9 stretch from a ZFS root successfully for over a year.

As for the “why”: Because ZFS is awesome. Even though I can’t use its “self-healing” features since I only have one drive, I still get the benefits of datasets, snapshots, the ARC, easy replication and backups with ZFS send/receive and the security that no matter what, ZFS will never return “bad” data, even if my drive starts to become flaky, thanks to the build in checksums.