[solved] Please help: My GPU is running at 1/3 speed

HELP! I used to get 9993 in Firestrike and now I'm getting 3178.
Here is my system and specs.

Either I don't know what I'm doing (most likely) or my GPU is messed up.
My GPU o/c refuses to budge and it's at 1/3 stock frequency.

I hadn't run Firestrike in a few months. The only thing I've changed other than keeping the drivers updated, is I added an Intel 750 SSD. I checked my CPU o/c and everything seems Ok there. I have o/c profiles in Afterburner and I also tried the MSI gaming app. I apply the o/c and it seems to go in, but in the test it is always stuck at 405 MHz. The weirdest part is I monitor my frame rate quite often and haven't noticed any drastic (1/3) change. I still usually hover around 60 fps in most titles.

Shouldn't I be getting 20 fps now?
Isn't it odd that both the core clock and memory clocks are exactly the same?

Admittedly, I don't mess with my GPU o/c that often. I assumed it was the same as 6 months ago. My Afterburner settings are the same. Now I am clueless. I have a headache and I should go to bed and try again fresh in the morning.

Hopefully when I wake up some Level 1 techs will have a couple of solutions for me to try.

Thank you for your patience.

nvidia driver 376.33 is really buggy, try rolling back to a older driver.

on my 770 I run HWmonitor while gaming and I usually look at the temp.
When it runs at 81 I know its running at top speed, 82 degrees and I gotta pull fuzzy's of the blower fan.

Also most updates will adress new stuff like VR or new games that come out. One time on a lark I read the "release notes". Saw problems with games I have listed.

Nvidia came out with it's own version of AMD's Razor, after installing I saw an 8fps drop in Valley.
Hope this helps some

When I learned programming, they made us do it on punch cards because it's too quick and easy to mash random guesses into a terminal. Often the best solution is to walk away and take time to think it through.

So like a good engineer, I thought about it and wrote down a checklist of possible solutions. Then like a bad engineer, I did them all at once so I could never tell which one fixed it or fucked it up even worse. My GPU temps are only around 40C @anon85933304 , so I don't think that was the issue.

I scrutinized motherboard UEFI BIOS for anomalies. When I got the Intel 750 SSD I had to flash the BIOS and that was a change that could be a possible problem. I changed the graphics from AUTO to PCI-e (could be important).

I uninstalled MSI Gaming App and MSI Dragoneye.

I updated MSI Afterburner from v4.2.0 to v4.3.0

As suggested by @fredrich_nietze I rolled back my Geforce driver to WHQL v376.09 and did a custom clean install.

Then I looked in the Geforce forums for the highest possible Afterburner o/c settings for a GTX 970 and tried that. I didn't try going any higher because the o/c has not been stability tested yet.

When I ran Firestrike this morning I achieved my best result ever!
Even better than when I briefly owned an R9 390 AMDorks!

And to think, I joked about being afraid to install the latest driver and sure enough it fucked up my GPU.

Thanks for the help, but the problem was mostly that it was 3AM, my gray matter had turned to clay and I was frustrated.

1 Like

What the 20somethings look like reading this


20 something here. I know what punch cards are, though I have never had to use them.


Then you never had to put them back into numerical order when you dropped a 4 inch stack of them while waiting in line at the card reader.

I wouldn't wish that on my worst enemy.


Hell , I am over 40 and never used them. See some once :)

1 Like

At UCONN they forced all the freshmen to use cards.
They said it was to learn us a lesson in critical thinking, but I think it was because the computer center was way overcrowded. The rule was if you got up from your terminal for 1 second, when you got back someone else was in your seat.