[Solved, not fixable] Sleep Issue on GA-AB350-Gaming

Ive just built a Ryzen system (1700x, 16gb, 256g evo ssd, 1050ti) and so far I love it but there is one issue thats been quite problematic. If I leave the system for a day or two, no amount of shaking the mouse, spamming the keyboard or pressing the power button seems to wake it up. The strange part is, it only does this if its been a long time since Ive used it, off and on daily use and its fine.
Im running Fedora 26 with kernel 4.13.9-200.fc26.x86_64, bios is latest f7a.
If anyone has a workaround or is experiencing the same issue, any insight would be greatly appreciated.

1 Like

A few preliminary questions:
Are fans and drives still spinning?
Can you see it/ ping it on the network?
Do you have an overclock or any power changes?
What are your sleep settings?

Fans and drives are still running, lights are still on
I havent tested the network but that is probably a good idea
Theres no OC, all OC related settings are default
Its set in “Blank Screen” mode so not a full sleep

I suppose that is all rather important and Im an idiot for not thinking to include that in the first place

Okay, I have had a similar issue with my system when pushing the limits of my overclock which obviously isn’t the issue for you. I have a friend who had the same issue and was fixed by reseating the RAM.

I would disable the screen time out and see if the screen stays on when this issue happens. For me the screen freezes as well as the audio and I cannot detect it on the network. Just like you the system otherwise appears on.

I have had a couple of random lockups that required a reset. this sounds like it could be the issue.
I did have a no-post after I first built it and reseating the ram seemed to fix it. maybe i just need to clean the contacts really well and put it back in.

I have similar hardware and the same issue. PC becomes unresponsive to inputs after leaving it idle for a long time.

Ryzen 1600x
Asrock AB350 ITX with latest BIOS (3.10)
Fedora 26

I went as far as to discover errors similar to this in logs

but have not done any further troubleshooting.

I lost my login so I realize this is a really old post but I think I may have found the issue.
It has something to do with the watchdog timer and nvidia graphics cards. I do get a module error from sp5100_tco about an address being in use so I think that could possibly have something to do with it. My guess is that the kernel isnt initializing the WDT correctly and until theres a patch there is nothing that can be done about it. I guess Ill just have to live with pressing the reset button for now.

unfortunately theres no easy way to get logs from it since I have to hard reset. I havent tried sshing in yet